[A14/A15] The buildings my hearthling will not build Thread

my attempt to build a dojo style house will not finished. Everything looks good (can’t see missing blocks) but the scaffolding will not removed. The template is builded with single blocks and the second level is build with the “floor” tool.

dojo.zip (4.2 KB)
dojo_wont_build.zip (9.4 MB)
dojo.zip (4.2 KB)

1 Like

Giant Hearthling save.zip (4.8 MB)
See attached the savegame of the statue.
Thanks for your answers, I already tried to get rid of the ladders by building ladders for the hearthlings to reach the unwanted ones. Unfortunately these few that are left can’t get removed with that trick :disappointed:.
Maybe you can find a way to fix this :slightly_smiling:.

1 Like

Cool dojo, @talamatur! Am I right in thinking that you built that structure before the very latest unstable a15 (2867)? Some important changes just went in to the latest unstable that should make your dojo buildable (there actually are unfinished blocks in it; switch to the flat rpg mode, and look at the top part of the steeple in the dojo, and you’ll see some flooring that is missing, that hearthlings can no longer access, and so can no longer complete.) Unfortunately, that means that you have to design it again. Sorry! There’s no good way to fix up old designs prior to 2867, but the good news is that this should make many more structures buildable.

5 Likes

Stone Manor.zip (81.1 KB)

I gave multiple building templates in that zip, because I saved it in stages as I designed it. That might help you guys I figure. ALso, here is the save file, because it wont actually let me place the building template in the game, but you can see and edit it in this save. Also the hearthlings wont even attempt it, and there is some sort of error involved.

2 Likes

Another one staying unfinished. Reason seems to be the one wall left of the stairs. Hearthlings left it undone but continued happily with the rest. Until they just stopped.

housestayingunfinished.zip (187.1 KB)

1 Like

Building is not stuck, but my worker “Alex Quess” is pingpong back and for while removing the remaining scaffolding. After some time an other worker (“Lia” in my case) comes and does the same. This takes a lot of extra time for building.
I build the dining room from the standard templates.

using the decor mod [Mod] Settlement Decor Mod [Download available]

worker_pingpong.zip (6.0 MB)

1 Like

so today i try building a build i am trying to make or the past 6 months, and they failed.

This is my design


And This is what they build before completing stop

From what i observe during the construction, they start building scafoldings and ladders before complete the ground level, and the others ground layers, so many scafolds clip inside of the blocks and they never ending building the smaller bits

5 Likes

A quick A15 D2871 update on my Watchtower template:

  • I redesigned it fresh on D2871 (same design, just made the template again fresh).
  • The builder no longer wigs out when designing it or when trying to place it in the world (YAY!)
  • Discovered that you apparently can’t delete windows or roofs once they’re placed on a building. Sad day. :cry:
  • Generated a builder engine error by console-destroying the windows from the design instead. (or at least I think that’s what caused it, because once I reloaded the game, removed the in-progress design and placed my freshly saved template instead, I didn’t run into the engine error again).
  • The build can be started this time! (YAY!)
  • My Hearthlings actually built the building swimmingly, all the way up until the final floor and the slabs that make up the rooftop and battlements, where the build abruptly stalled indefinitely.
    ** I would have used the builder’s pre-made battlement roof, but the builder UI doesn’t let me erase parts of the floor, to provide a path up from inside the tower, so I made my own with the floor tool and slabs.
  • Sidenote: Because my design has a fully-functional spiral staircase interior, the required scaffolding was … intense. I had to chop down a great many extra trees just to cover the scaffolding cost (something the new building materials calculator does not take into account; or if it does, it doesn’t do so accurately, as I ran out of wood midway through the build due to the excessive scaffolding). On that note, love the new building cost summaries! Thank you! :slightly_smiling:

Template:
stone watchtower.zip (18.1 KB)

Screenshots:
Where it stalled:

What’s left to build:

Also paging @not_owen_wilson in case this is of value to his current research.

3 Likes

This was planned and has not been built in the water (I ib it as a test) …

…but will not build on the surface too, but others I tried and constructed the same way to reproduce it will …

waterhouse.zip (3.0 KB)

2 Likes

In 2871 I designed a fairly plain 2 story shared bunk house. Normal floor for ground floor, slabs for internal staircase, slabs for 2nd floor, standard walls on both floors, standard roof, 1 door, 8 windows per floor. Saved it. Tried to place it, got an exception popup, game kind of placed the door and a couple of the windows to be built but nothing else and in many UI modes now I’ll continue to see those floating never built elements (since I cancelled the build). I can also never place the template for this 2 story building - the ghost for it never appears if I try to build it elsewhere.

I’m also not sure how to mine upwards successfully, like I wanted my hearthlings to mine on “floor” above the “room” I carved in at ground level. I chopped a hole in the side of the “hill” (with normal ladder) so they could get there and built a connecting staircase once I could successfully. Then I tried to fill in the upper cut with a simple slab wall - they built the bottom row of that but have never finished the job and left scaffolding there for it. The can easily get to both sides of that and sorta shouldn’t need scaffolding for such a simple job if they did it from the inside, but instead they made ladders and scaffolding from the outside.

1 Like

This actually builds on my local build! I’m not sure if that means some errant non-determinism has crept in, or some of the pending fixes I have are sufficient to fix the problem. Will keep fiddling, and thanks for the template!

5 Likes

Could it be the way it falls on the chunk that determines how it builds? I know they’ll build some parts of a large build first so it’s somewhat cutaway looking and then finish the other chunk’s parts.

2 Likes

Quite an amazing building XD, It must be a sheer aesthetical feast when the castle is built !

1 Like

Awesome temple! It also exposed some nice bugs :slightly_smiling: . Should build by the next unstable push. (Though do create some holes allowing entrance/exit into your temple’s roof! Otherwise, poor hearthlings can’t get it to tear down scaffolding and such).

4 Likes

i am happy to see it help found any bugs, and more happy to know they will build it next time

1 Like

Well, I don’t know if the hearthlings are smart enough to build it completely yet, but the instabuild method works now! Much thanks to Team Radiant for all their hard work to make it happen.

8 Likes

This is the building I have been attemping to build

When I confirm and attempt to build it, this error pops up :

Error

develop-2876 (x64)
...onehearth/components/building/building_component.lua:780: attempt to index local 'entry' (a nil value)
stack traceback:
	[C]: ?
	...onehearth/components/building/building_component.lua:780: in function '_add_dependency'
	...onehearth/components/building/building_component.lua:1048: in function 'wire_dependency'
	...onehearth/components/building/building_component.lua:1059: in function 'wire_dependency'
	...onehearth/components/building/building_component.lua:1059: in function 'wire_dependency'
	...onehearth/components/building/building_component.lua:1067: in function '_compute_spatial_dependencies'
	...onehearth/components/building/building_component.lua:932: in function '_compute_dependencies'
	...onehearth/components/building/building_component.lua:306: in function 'set_active'
	stonehearth/services/server/build/build_service.lua:95: in function 'set_active'
	stonehearth/call_handlers/build_call_handler.lua:19: in function <stonehearth/call_handlers/build_call_handler.lua:18>

I have also been recieving these errors on load :

Error 1

develop-2876 (x64)
...ehearth/renderers/fabricator/fabricator_renderer.lua:23: assertion failed!
stack traceback:
	[C]: ?
	[C]: in function 'assert'
	...ehearth/renderers/fabricator/fabricator_renderer.lua:23: in function <...ehearth/renderers/fabricator/fabricator_renderer.lua:13>

Error 2

develop-2876 (x64)
...ices/client/renderer/construction_render_tracker.lua:20: attempt to index field '_bp' (a nil value)
stack traceback:
	[C]: ?
	...ices/client/renderer/construction_render_tracker.lua:20: in function '__user_init'
	radiant/lib/unclasslib.lua:270: in function '__init'
	radiant/lib/unclasslib.lua:201: in function 'ConstructionRenderTracker'
	...earth/renderers/scaffolding/scaffolding_renderer.lua:49: in function '__user_init'
	radiant/lib/unclasslib.lua:270: in function '__init'
	radiant/lib/unclasslib.lua:201: in function <radiant/lib/unclasslib.lua:199>

Error 3

develop-2876 (x64)
...onehearth/components/building/building_component.lua:313: attempt to index local 'entity' (a nil value)
stack traceback:
	radiant/modules/common.lua:223: in function 'report_traceback'
	radiant/modules/common.lua:234: in function <radiant/modules/common.lua:228>
	...onehearth/components/building/building_component.lua:313: in function '_trace_entity'
	...onehearth/components/building/building_component.lua:123: in function '_restore_structure_traces'
	...onehearth/components/building/building_component.lua:77: in function 'obj'
	radiant/modules/events.lua:73: in function 'instance'
	radiant/modules/events.lua:206: in function <radiant/modules/events.lua:200>
	[C]: in function 'xpcall'
	radiant/modules/common.lua:243: in function 'xpcall'
	radiant/modules/events.lua:200: in function <radiant/modules/events.lua:171>

Attached building template here. This bugged building.zip (29.6 KB)

3 Likes

Build 2876: This one almost gets built. The oriel starting on the second floor won’t get finished, though, due to slabs being attached in front of only the upper half of the wall. Result: Third floor gets completed before that part is done, leaving the Hearthlings unable to finish it.
Almostdone.zip (92.4 KB)

Other than that, the new build already feels heaps better than ever before, building wise. Keep up the great work.

Edit: And another one: wall2876.zip (46.2 KB)

1 Like

Thanks for the template! This was the result of an awfully old bug whereby free-standing walls wouldn’t merge with adjacent structures (like the floor) correctly. Should be fixed for next build (but will require designing the structure again, sorry!)

7 Likes

Okay, Almostdone now builds (it was a structure dependency issue, so a nice and subtle bug that’s been waiting around for me to squash it.) Your “wall2876” is weird though, there seem to be two overlapping walls causing an issue. Any idea how you managed to lay down that structure?

3 Likes