A couple of bugs i have seen

I made one game and tried to do a bit of a spin off of the dining hall shown in one of the videos (cuz im new and just trying to figure it out)…

they would not move the chairs for dining from the stockpile to the building… period… i tried undoing the command and retrying, i tried moving the tables around… also had the same issue with ONE bed in one little 10x10 shack i made. it just wouldnt go… also noticed on a couple of the other shacks the doors were missing so apparently they didnt want to move those either…

and now the tragic part… 2 people died because of this next bug!

my carpenter and trapper both got stuck on a ladder with a goblin… possible love triangle?

i sounded the alarm after randomly seeing that my blacksmith had died (was murdered)

my two footmen did nothing… they patrolled the stockpiles as normal while one of my helpless workers was modded and overrun by 3 goblins.

all while my carpenter and trapper got fresh with a goblin on a ladder…

here is a pic of the door and bed issue Image - TinyPic - Free Image Hosting, Photo Sharing & Video Hosting

and here is the picture of the buggy good time Image - TinyPic - Free Image Hosting, Photo Sharing & Video Hosting


Hi again @Jezebel, Yet this is tied to the A.I. bug. Another one they are working on. Admittedly the goblins hearthling bug is rare.

Work around: The bed issue, just click on ghost bed and move it again or find the bed in stockpile and reclick the spot, sometimes that works.

The hearthling stuck on ladder, just break ladder down and they will drop or should. If they don’t then reput a ladder back too them. Should get them moving again. (sometimes saving and reloading game from desktop get the A.I. going again too.

1 Like

thanks ill have to give it a try (the ladder bit)… reloading the game normally helps a lot of things… unfortunately it didnt help the massive lag from my large building i am working on right now haha!!! the LUA is through the roof

disclaimer: i know this is alpha and im not complaining just throwing things out there that i notice that i have not yet seen in the forums…