[Dev 2391 x64] Multiple bugs

Serious bug with the GUI. Every once in a while the interface will just cease to exist. The menus will open, but they will be blank. (I’ve sometimes caused this bug by just adding someone to a party.)

The save menu just sometimes doesn’t work, at all. I’ll be able to save it, yes, but then I can’t close the window. It’ll stay there until I alt-f4 because I can press escape, but can’t operate access the main menu. (Sometimes happens, sometimes doesn’t.)

Undeploying furniture such as the carpenters workbench. It’s as if the undeploy button doesn’t work. Same for beds, which can be a real pain if they don’t undeploy. (This has been going on for multiple versions I’ve found…)

Also, the UI boxes seem to be too small for the icons. Maybe a simple mistake with the new interface?

Please do chime in if anybody has had these!

Edit: Just found as playing now. I built the shared sleeping quarters and as they were building ladders and scaffolding for the roof, they had to be built ontop of a berry bush and my camp fire respectively. So the segments of the ladders that are out of 1 (or 2(?)) voxel reach of the hearthlings, are stuck floating over top of the berry bush and a segment of scaffolding just happened to be floating overtop of the camp fire. I tried removing the bush but did not remove the ladders and same for the scaffolding/camp fire. (Maybe I just don’t know how to remove ladders and such after the fact?)

In the image, you can see the ladders on the left next to the error menu and scaffold over top of the fire. That error menu is also new on my reloading.

8BitCrab suggesting to build ladders up to them worked. I was hesitant being I’ve never really used ladders much and never knew if they could be removed.

Edit: Eraser also seems to be broke? Maybe it’s just due to my ladder problem.

1 Like

welcome to the discoure @AfyKirby_Official :smile:

i know that this has been reported somewhere else, thanks anyways :smile: .

as for the others im unsure, i will check around.

1 Like

Great but not so great to hear I’m not the only one with a bug like that. Thanks. :smile:

1 Like

currently there isnt a way to remove ladders/scaffolding that the hearthlings build,

perhaps try manually building a ladder up to them?

edit: also @SteveAdamo @Relyss looks like a picture needs to be embedded :smile:


done and done… :+1:

p.s. welcome aboard @AfyKirby_Official! :smile: