Working on my first ever mod, Will share more soon!

Hey everyone, After a long break from the discourse / Stonehearth I have returned with a new goal / idea, However I’ve spent the last entire day trying to figure out what I’m doing wrong, I can’t get this to show in the crafting menus or become wearable, I’d settle for just wearable but have no idea how xD

My hearthlings are as confused as I am, This is what I’m trying to make wearable, its a modified winter outfit.

I have referenced it and everything, I’m adding images because It won’t let me upload the files, although I could probably upload it somwhere else

I have failed badly and tried everything, If you could help I’d appricate it so much, Thank you, And sorry for being such a noob, Its my first attempt at a mod, There’s a few other bits I’ve done but none that should effect this.

1 Like

alright, first question, is the suit multi-matrix? (and what voxel editor did you use)

also, welcome back :smile:

1 Like

Thank you :smiley:

I’m using the stonehearth version of Qubicle, but strangely I have every version of Qubicle :smile: Now for the part that makes me feel stupid, I’m not sure if its multi-matrix, I would like it to be used just like normal winter outfits just with the different look, Sorry I’m useless at describing things, its why I spent an entire day trying and failed, Hopefully you understand what I mean, if not I’ll try to be more detailed xD

1 Like

alright, qubicle is good (supports multi-matrix stuff) would you perhaps be able to provide me with a download for your mod so i can check out the files and see whats what?


Thank you, I appreciate your help so much, It means a lot, its been killing my head all day, I was using one of the default mods to use as a reference as to what to do, so all the default stuff is there too (mainly cause when I delete it, it stops showing up the suit, I’ll re-write the entire thing as a new mod when I can find out what’s causing it to be derpy,) It shows up when I type suit with the dev tools I can place it but I can’t get it to be craftable or for hearthlings to wear it, I just know I’ve ever not done the most basic thing or missing the complete obvious xD (601.3 KB)

Thank you again :wink:

1 Like

alright, i’m busy right now so i can’t check it out, but when i get time later i’ll see whats what :slight_smile:

1 Like

alright, i got the time to check it out.

fired up the game with the mod and was able to place the suit just fine, i believe the problem you might be having is not having checked the “iconic” on the item dropper tool,

if that’s not checked it just places down the normal version of the item, if it is checked it will drop down the iconic version, and the iconic version is needed with equipment.

so while i think that’s the problem you were having, i could be wrong, so if you could double check and/or confirm for me that’s what was wrong that would be great :slight_smile:

1 Like

Wow… I don’t know how to feel now… I’ve just been trolled by a tick box for an entire day. Thank you so much, That worked I feel even stupider now, I never even noticed that box, haha just glad it works now xD

Thank you again @8BitCrab you’re the best, Really appreciate the help :slight_smile:

1 Like

Ok it fully works now (if you call a footman stealing and and using it as working xD)

Time to edit him and get the rest of this project working, Its actually feels worth all that learning now xD

I should hopefully be able to share the project later this weekend, if not then by next weekend, hopefully it works like I hope it too :stuck_out_tongue:

Workers now wear them yay!