Getting somewhere but need some help

Alright first off hello stoneheart comunity i am back from the grave. When stoneheart got launched on kickstarters i was one of the backers and at that time i went full hype and created all kind of content with quibicle to add as mod later when modding would become posible. I have been gone for more then 2 years and i think now is a good time to start and create the mods i wanted to make since the game is at a state i find worthy of creating content for.

Well that was my comeback speech now on to the practical part. I am complete novice if it comes to modding and programming so this is a first for me. i am a quick learner and by reading the files created by the developers i was able to create my first own content that already works. There is only one minor problem i am expirencing and that is that i can not get the descriptions working. Everything else works just fine.

I would like to ask any modder who knows what they do to look at my file and see what i have done wrong. I would be very thankfull. Since once i have that working i can start adding all my content to the game and i have quite some content ready to add.

Its a small file with only 1 items that is made by the weaver. its a decoration item for on the wall. to be precise it is the Nachtwacht (nightwatch).

Dropbox: yangdecorations

Thnx in advance and its nice to be back. i am quite curious who still remembers me :stuck_out_tongue:

I’m a modder, but i never code, so i’ll page out micghy coding masters!

@BrunoSupremo @Wiese2007 @RepeatPan @Froggy

1 Like

Your en.json file is corrupted somehow. :sweat: The text/code is perfect, nothing wrong in it.

(after a lot of suffering trying to figure it out) :angry:

What I did was just copy the contents of en.json. Delete it completely. Then create a new one, pasting the text into it. Done, it worked. :expressionless:

I have no idea why though. Hope it works for you too.


Thank you that fixed it! ill soon make a post with a first version of my mod!

Now i have another question. i have armour and i made it in to pieces and i am looking into the standart files and see them named. but the names are not stable. the number behind differs. any clue what number i should use?

The models has to have the correct names, cause this is how the animations know which pieces to move (the animation looks for specific names)

The number depends, what exactly number are you talking about? The defense? ilevel?

1 Like

well some rightHand’s are called righHand_7 while others are just rightHand

and i am currently naming them. Also do you know if i have to export in righthanded z or lefhanded z in quibicle. cause for my decoration it was righthanded but the first test of armour was located about 1 hearling away from his body xD.

and jet another question what term must i use for my armour to replace it instead of merge with it as als the other standart armour pieces do?

thanks for all the help!

Uhm, I think those numbers are the fingers? not sure, these is already out of my knoledge (I’m bad at the models parts)

About the models being far from the hearthling, I also had this problem, but I used another software. So I also don’t know how to help here. (just wait, there is plenty of guys here that will be able to help in this)

To merge there is this:

     "render_type": "merge_with_model",

(from one of the game’s armor)
And also:

        "transparent": "true",

I’m not sure the differences between them. (I think one complements the other)

1 Like

Your en.json contained an UTF-8 BOM. Make sure to save your files as just UTF-8, without BOM.

"{ \r\n   \"jobs\": {\r\n      \"weaver\": {\r\n         \"recipes\" : {\r\n            \"nachtwacht_recipe\" : {\r\n               \"recipe_name\" : \"Nachtwacht\",\r\n               \"description\" : \"Made by Rembrand van Rijn\",\r\n               \"flavor\" : \"A master piece!\"\r\n            }\r\n         }\r\n      }\r\n   },\r\n   \"entities\": {       \r\n      \"decoration\" : {\r\n         \"nachtwacht\": {\r\n            \"description\" : \"The master piece made by Rembrand van Rijn\",\r\n            \"display_name\": \"Nachtwacht\"\r\n         }\r\n      }\r\n   }\r\n}   "```

The ``is the BOM. I suppose Stonehearth doesn't deal with BOM properly and because of that, the JSON parser assumed that it was malformed JSON (because it started with ï, which isn't a valid part of... any JSON outside a string, I believe).

<small>(Also, "night watch" in German would be "Nachtwache", not "Nachtwacht", but that's nitpicking now and could very well be for artistic reasons... But you know, as a heads up.)</small>
1 Like

Thx for the tip but i have no clue how to do that xD. i just create a text file and change the .txt to a .json and that works almost all the time but it seems to fail some times. How can i change this?

And i know my languages. The actual original name is De Nachtwacht it is made by a dutch man named Rembrandt van Rijn. So the name is correct since its a dutch masterpiece and not german :wink:

Apologies, I’ve come around pseudo-German too often recently.

It should be an option in your text editor, probably named “Encoding” or something similar. Which editor are you using?

Haha np man. i did it with wordpad and that didnt had that option. I dowloaded PSPad and i can change it now. thx!

I then recommend sublime text editor, it is really good. Has syntax highlight for a bunch of languages by default and has a lot of quality of life functions.

By default it saves the files with the correct encoding.

1 Like

well here is my mod page [MODS] Yang & Co's Mod Making [A22.5][A23]

1 Like

The numbers you can ignor xD this happens when you have more then one entitie with the same Name… The stonehearth System only recognize The Name left_hand etc

1 Like

Best is you download sublime text for the formatation xD there you can save it correctly

And Sry for the short answers ist have only Internet via Handy at the Moment xD

np! the awnser is what is was looking for. no need for more text then needed.

Alright i have another question. en.json does not seem to like me. I am using sublime text editor.
here is my file
there is a an.json and a en.json
i called the one that didnt work an.json cause you can not have 2 files with the same name.

Now here is the problem. I went back on an older version and added part by part and found out that:
“mastersword” : {
“description” : “A very strong sword”,
“display_name” : “Master Sword”,
is the problem. i went and manually typed it over in the new one and it worked so there is something wrong with it. Problem is to me the
"mastersword" : {
“description” : “A very strong sword”,
“display_name” : “Master Sword”
"mastersword" : {
“description” : “A very strong sword”,
“display_name” : “Master Sword”,
look exactly the same to me. can a profesional tell me what is wrong with it so it wont happen again.

thank you in advance

There is an excessive comma after [quote=“Yangzhoui, post:18, topic:26981”]
“display_name” : “Master Sword”,

in your second version.


thank you
i know to look out for that but i just couldnt find it this time
i have dislexia so stuff like that is my weakness

thanks again!

1 Like