With the new Alpha Build, my hearthlings won't build on/under the water

Been making my Water town, and tried out the new alpha 20 today, but I think it looks like that hearthlings won’t build under/over water anymore.

Anyone else found this to be true?

They will build on land, I checked.

Repro; Build a structure in the water, make sure structure has its feet on the bottom of the lake and hearthlings have access to the lake via ladders.


Dat village…
Damn. Just damn.


The most painful thing about it is that you have to build everything fresh, you can use saved designs, as they don’t place correctly under the surface of the water.

Painful but totally worth :smiley:

1 Like

Yes, placing templates in the water is hard cause we can’t know exactly where it is going (it shows in the surface)
One thing you can do is build the platform by hand, and then plop a template above it.

Could you upload this save? It would easier to test your bug.

Sure thing, I have the auto save, it’s definitely from alpha 20 since I can’t load it in alpha19.

Hope it helps!

Good idea about the platform too, I should try that.

Oh I forgot the upload save: Dropbox - auto_save.rar

@Anuxinamoon, I’ve loaded your savefile and hearthlings are busy building a small house near the mountain.
I’ve paused it, and they started to build the underwater structure.

Tried to reproduce on a new game, and they start buliding as long as they have ladders to reach the bottom of the water.


So unfair, why does it always work fine on the engineers computer? :stuck_out_tongue:

I’ll try again today! Thanks!

Alright a little update, I started construction in alpha19, they started building, then I updated to 20, they kept building. I Figured it was alright, but they just stopped building and I cant get them to restart it.
I unticked all activities except building, I have restarted the game, updated tot he bugfix patch. But no go.

They will go into the water to place things, so it’s not a water thing. Maybe I broke the save file? I’ll try to load a previous one.

Thanks for your help, regardless! I will keep trying to see what is going on.

Feel free to bump this thread with a new savefile if you think something else is broken on that game.

When they stop building it can be that they can’t reach some place to place or tear down scaffolding, or ladders.