Attempting to place pre-built buildings in water results in floating placement

When attempting to place a pre-built building in the water the result is a difficult situation for the user as it is pretty much an educated guess at best when trying to place in a specific location.

Steps to reproduce:

  1. Launch Map that has a decent body of water
  2. Using a pre-built blueprint, attempt to place the building in the water
  3. Observe during placement the building ‘hovers’ over the water. Unable to recognize the water blocks as any different from any of the other material blocks(the ground).

Expected Results:
When placing a building in a body of water, the placement tool ‘see’s through’ the water blocks and continues to use the ground beneath the water as the placement location.

Actual Results:
Buildings float over the water making it difficult to place in a specific location

The building does drop to the ‘ground’ level once placed


Version Number and Mods in use:
2881 - Latest unstable / None

System Information:


my suggestion is to add the blue print of your build or the savegame file so the dev team can see what happens and test it out.

1 Like

Good call, Doc, I have everything needed for that but I do not think it is a 1-off as it happens with any pre-built (for me so far at least). Also, this is a pretty easy catch and they probably already know… just in case I throw the info up and if they need anything, I’ll grab it for them.

pre/built for you maby, but the original builds that come with the game are not really made for under water i believe :slight_smile:

It’s just easier for the devs to have a build it happens with and not having to design one them selfs.

Ok, first off, why are you wasting your time trying to be hoity toity with me? I am attempting to help, are you or are you just telling others how you think they should help? I don’t get paid, these mods get paid to read this stuff and they are not only good at it but they are nice about it as well. So if they need something from me, I’ll gladly get it for them.

Secondly, have you even tried it troll? “original builds that come with the game are not really made for underwater”…? Ummm, excuse me? Is there an option we flip for underwater building? Gimme a break, and the answer is no before you get confused. Once placed they ALL end up on the ‘ocean floor’ so to speak.

I tried to be nice in my previous post but I cannot abide a looky loo, not willing to even put in his own time to try it out before telling me let alone someone else how to help.

PS- That’s a Dining hall “not made for underwater”… which is why it floats when attempting to place it but on the body of water’s floor once placed… AS IS WITH ANY PRE-BUILT!

For the mods - this is a regression at least as far back as 2881

hey there @MickDodge,

no need to get upset, @Doc_Brano was just trying to help us (the mods) out by eliminating possible causes of the bug.

we (the mods) are actually a volunteer team.

i dont need anything else, Doc_brano basically covered what i was going to ask for, and i dont really have anything to add to what Doc said either…

however, i will page @not_owen_wilson for you as i’m pretty sure he works on building related stuff.


8Bit, I’ve been on the testing side of your work for years and I applaud you and those that do what you do. However as far as what a tester needs is in my bug and for someone with their console on with their current build(whichever they are on today), it’s a 20 sec check to see if it repros. If so then check build <2881 for regression. Wrap it up in a pretty bow for the devs with whatever additional info they already know they need and send it up.

Doc, my apologies, I should not have over extended myself emotionally. Going forward, please note that you come off arrogant and assuming and would be met with a much better response with a little bedside manner.

1 Like