Escaping water (r898 release)


#1

Summary:
I wanted to build a fortress on a lake, so I tried to make it in peaceful to see if it’s possible. I finished the building, then I ordered hearthlings to build it but I expected that the water level was reducing. At least only one bloc of water stayed. I did not use dry stone to remove water.

Steps to reproduce:
Try to build a big building in a lake?

Expected Results:
/I don’t know actually/

Actual Results:
Hearthlings build correctly the fortress but there is no more water in the lake.

Notes:
It seems that there is a rift in the lake that appeared after building order.

Attachments:
https://drive.google.com/drive/folders/1u8DLnsBBWon4TCzdQLQkBDVdA59L45B7?usp=sharing
A drive with my save (water was already getting away)

Version Number and Mods in use:
r898 release (latest build)

System Information:
Intel® Core™ i7-6700HQ CPU @ 2.60GHz, 2601 MHz
Windows 10
RAM 8 Go
GeForce GTX 960M


#2

Hey @Azu, did you destroy some building or blueprint in the water at some point?


#3

I’d just like to chime in and say I’ve had this happen also with placing summon stones in the water – specifically the island landmark from the Archipelago mod (dunno whether that makes a difference.)

It seems to happen when there’s “air” in a template – like the water is being removed by the template ghost, but never stops flowing into that place so it’s continually removed until it’s all gone. Unfortunately, deleting the template doesn’t fix the problem; once the “hole in the water” exists it doesn’t go away until all the water is gone…

Adding more wet stones (even in the dry patch) doesn’t update the “hole in the water” either, in fact the whole body of water seems to get stuck in a continuous drain unless it’s physically blocked off/separated from the “hole.” So I suspect there may be something going on with one of the water regions getting stuck thinking that water needs to be removed from a certain area.


#4

Yes I destroyed the same building once to move it. I think YetiChow is right, it seems to be the same problem.


#5

I don’t think landmarks were meant to be placed inside the water, at least not via summon stones. They will impact performance, especially in huge lakes like in the arctic or the archipelago biome.

The fact that the water doesn’t raise when we place solid objects inside it was made for stability reasons. But sadly, that means that when we remove those objects the water level will decrease.

If you see when you place a landmark inside the water, it will remove the water inside the square that it occupies:

So when the geomancer actually places it, the water around this square will merge with that empty space to fit the shape of the landmark, decreasing its level by a lot.

Not sure if we’ll be able to do something for building, although I find it strange that just 1 building can drain a whole lake of that size. There might be some buggy condition there as YetiChow suggests :thinking:


#6

I tried placing that exact crab island summon stone into the ocean of the Archipelago with my Geomancer, and it crashed my game. I think it said that Stonehearth ran out of memory, a fatal error.


#7

It makes sense that buildings and summon stones would remove some water when being placed – when @max99x and @malley were explaining how the summon stones worked they mentioned that they override nearby terrain so I assumed that would mean some water deletion. And frankly it wouldn’t be hard to deal with on its own anyway; it’s the continuous drain which is the problem really.

Come to think of it, I had the same issue when I tried to put a geyser landmark in a lake – I thought it was an issue with the geyser’s wet stones needing to be “refreshed” (which I was eventually able to do by literally filling all the gaps with wet stones and then removing some to update their flow… I thought that updating the stones themselves was what fixed it, but I’ve just realised it might be because I fully filled the “hole in the water” so when I removed some wet stones they were able to fill in the gaps now that the continual drain was gone.)

I wonder what would happen though if @BrunoSupremo updated the crab island to include a water border? Would that remove the “hole”, or would it lead to an “invisible hole” where the border of the landmark-placed water still “eats” the surrounding water because they haven’t mixed/equalised yet?


#8

im assuming filling the landmark’s holes up to its bounding box with water should stop the infinite drain-flow (since there is no air to flow to) not quite sure how it would behave -AFTER- that though.


#9

Same. It freezes for so long that it may end up crashing due to lack of memory.

That’s a good question :thinking:


#10

I can’t fix the water bug but as a small contribution to avoid spreading it, the island landmark will not be placeable anymore, only appear as a world natural feature. The modded geomancer landmark will now be a volcano. It ended being better anyway as it is easier to use and can fit in more creative ways.