Windowed Mode Not So Windowed


Haven’t played Stonehearth since the last stable alpha. Went to go to run it today, and I’m getting a full screen error that I sometimes get with other games…in windowed mode.

In other games, such as Eve Online, when I try to start them in borderless window mode, because I have a 4K screen and a 1080p screen, it will some times load the window in 4K across both screens. Well…Stonehearth is doing this every time I load it now.

The part of the window that’s on my 4K monitor will display fine, but the other half of it is just white, that when you try to click on it, clicks on whatever is behind it, whether it be another program or the desktop. If you try to minimize it to the start bar and restore it, it fixes it most of the time, but every now and then you get a System32 error; image below shows what I’m talking about.

I’ve already checked my user_settings.json, and it’s set

"enable_fullscreen" : false,

and tried to manually change the window size in the settings as well to something smaller (800x600) but that doesn’t seem to do anything at all.

Actual Results:

Sorry for the large image, but I just screenshotted my whole desktop to show you what I see. Top half is 1080p, bottom half is 4K.

Version Number and Mods in use:

R-826 (x64)