Water flows unexpectedly

Water flows wrong when filling mined areas
Steps to reproduce:

  1. mine an area next to a body of water
  2. connect the water to the mined area
    3)let the water flow until the error happens

Expected Results:
water equalizes across the entire body
Actual Results:
The water created a waterfall and then filled in at a lower altitude.
release-566 (x64)entity1 == entity2 in merge_water_bodiesstack traceback:
radiant/modules/common.lua:237: in function ‘report_traceback’
…arth/services/server/hydrology/hydrology_service.lua:671: in function ‘merge_water_bodies’
…arth/services/server/hydrology/hydrology_service.lua:775: in function ‘_process_water_queue’
…arth/services/server/hydrology/hydrology_service.lua:754: in function ‘_on_tick’
…arth/services/server/hydrology/hydrology_service.lua:52: in function 'fn’
radiant/controllers/nonpersistent_timer.lua:56: in function 'fire’
radiant/controllers/time_tracker_controller.lua:82: in function <radiant/controllers/time_tracker_controller.lua:82>
[C]: in function 'xpcall’
radiant/modules/common.lua:257: in function 'xpcall’
radiant/controllers/time_tracker_controller.lua:82: in function ‘set_now’
…hearth/services/server/calendar/calendar_service.lua:379: in function ‘_on_event_loop’
…hearth/services/server/calendar/calendar_service.lua:37: in function 'instance’
radiant/modules/events.lua:227: in function <radiant/modules/events.lua:221>
[C]: in function 'xpcall’
radiant/modules/common.lua:257: in function 'xpcall’
radiant/modules/events.lua:221: in function 'trigger’
radiant/modules/events.lua:290: in function '_trigger_gameloop’
radiant/modules/events.lua:338: in function '_update’
radiant/server.lua:62: in function <radiant/server.lua:58>
release-566 (x64)@stonehearth/services/server/hydrology/hydrology_service.lua:305: water transients not yet implementedstack traceback:
radiant/modules/common.lua:237: in function 'report_traceback’
radiant/modules/common.lua:456: in function ‘verify’
…arth/services/server/hydrology/hydrology_service.lua:305: in function ‘_link_channels_for_block’
…arth/services/server/hydrology/hydrology_service.lua:247: in function ‘_link_blocks’
…arth/services/server/hydrology/hydrology_service.lua:222: in function ‘_on_terrain_changed’
…arth/services/server/hydrology/hydrology_service.lua:92: in function <…arth/services/server/hydrology/hydrology_service.lua:91>

Version Number and Mods in use:
release-566 (x64) no mods
System Information:
Operating System
Windows 8.1 64-bit
Intel Core i7 3770 @ 3.40GHz 51 °C
Ivy Bridge 22nm Technology
12.0GB Dual-Channel DDR3 @ 799MHz (11-11-11-28)
4096MB ATI AMD Radeon R9 Fury Series (ATI)

From what I understand the water system is not properly implemented yet, so I doubt they really need any bug reports on it. Hopefully it’s something they’ll get around to in the not too distant future, so we can really do fancy stuff with the water, as opposed to now where the risk of breaking everything is quite high. :slight_smile:

I usually mine out 20-30 block long stretches of the area I want to fill with water then I will destroy one barrier at a time to let the water fill in each space on at a time. I always end up with zero errors and it fills all the way through.

I absolutely agree that the water systems are still pretty buggy, but I also want to draw attention to it so it gets fixed. With all this focus on building, we have a whole part of the environment that causes errors pretty much whenever we manipulate it. It just seems weirdly unbalanced, we’ve got all this space taken up by bodies of water and we can’t really work with them at all.

I try to make a water-project for every map I start, since building grand buildings are kind of out of the question right now(without help from the devs) I like a long-term project for my hearthlings. Draining a lake into an aqueduct around the town or making a reservoir that can store it can be very satisfying. And I haven’t even brought up the idea of fishing or boats to make water an important resource.

@cat_imma_kittycat: Thanks for the tip! I’ll try this on my next map. I hope one day that digging in water is more user-friendly!

So I dug a cave under that hill there to get water on the other side…

But in the first picture you can kinda see where I am expanding and the pattern I use to make sure the water stays put when I release each part.

I even managed to make a little tunnel to get cool water canal in my little town.


I don’t think it (water not working) needs attention. They know it’s not working and they will get to it, it just hasn’t been a priority yet. I look forward to being able to play around with the water too (I have tried as well, but yeah, you have to be careful :stuck_out_tongue:).
I don’t agree that it’s unbalanced - it’s two very separate things, building a house and terraforming the world, having the water react properly to it. It’s its own set of challenges and I think they’re doing the right thing by focusing on the building part first, since that is way more important.

Nevertheless a reminder like this, that we’d like to see water getting looked at never hurts. :smiley:

Didn’t they mention on one of the latest streams that it will be worked on water mechanics now over the summer to add some cool gameplay to it? :smiley:
I’m sure they will adress bugs too :wink: