Updated Alpha 10 building bug

The recent update to the alpha 10 build is pretty good.

However, something just wasn’t quite right with he build order(?)

I tried building a first floor building, no roof for multi-story building. Worked out the first time. People went to work on the building.

Second game, the citizens lazed about and didn’t do anything after gathering the resources. The building is made of wood and I had plenty of wood. In fact, the build order wasn’t particularly bugged(?) but the fact was that the citizens only built 1 story buildings with roofs from then on.

They didn’t even touch the projects with no roofs. Funny.

1 Like

Confirmed. Citizens won’t build a building unless there is a roof. Which means good-bye multistory buildings.

1 Like

It didn’t happen in my first game in the updated alpha 10 so that makes it seem even stranger. What went wrong?

so there has to be a roof on the first floor for them to build it?

Apparently so. I tested this out just now. I had finished the plan for a first floor. All wooden, no roof. Stockpile had both wood and stone. I ordered it to be built and the workers were idle for an entire day (since I had no other orders, except the trapper). Then I edited the building and only added a roof. That got the workers starting.

1 Like

This is weird because this wasn’t the case until I encountered some other bug in-game and then everything just went to crap. Now every game I start has this problem.

so your unable to get a screenshot?

I could but I don’t know how to attach them to my posts. Besides, a video would explain the bug better than a screenshot. A screenshot would just show a building blueprint.


are you able to get a video of it? if so that would be great :smile:

1 Like

I don’t know how to get a video or how to upload it. But I think my description of the situation is pretty clear.

But that bug doesn’t really matter anymore. The developers are unveiling a new building designer in Alpha 10 so this bug will become irrelevant soon enough.

wait… arent you using alpha 10 unstable? or are you still playing alpha 9?

I’m playing alpha 10 unstable. But the latest building feature isn’t implemented in the latest public unstable build. So I’m laying it off until the next update.

okay… now you have me totally confuzed, can you throw a screenshot up for me? i might be able to understand what your talking about a bit more

P.S. its not your fault that i dont understand, ive just been super tired and slow of mind lately :blush:

I don’t know how to upload media but maybe I can break it down for you step by step.

  1. I do not play Alpha 9.

  2. None of the posts I made refer to Alpha 9.

  3. The building bug topic refers the latest version of Alpha 10 (unstable)

  4. The building bug is as follows:

       - Citizens will not start to to build something unless it has a roof. This means that buildings are technically restricted to 1 story buildings.
  5. The developers are unveiling a new building system in Alpha 10 (stable) that will allow multi-story building.

       - This means that my bug is irrelevant because the current Alpha 10 (unstable) does not feature the ability to draw a multi-story building plan (it does but it ends up as looking more like a Ziggurat than a tower).
       - The current [latest] Stonehearth Alpha 10 [unstable] build available to the public does not have the new building feature.
       - Alpha 10 [stable] has multi-story building planner. Alpha 10 [unstable] [latest] does not have multi-story building planner.
       - Alpha 10 [stable] is not yet released.

I hope this clears up any confusion. I don’t know what your situation is but college finals are approaching for me. I’ve already taken most finals before classes ended but I still have some finals on final days.

P.S. A screenshot doesn’t make sense or at the very least, be unable to provide solid proof. When your mind clears and you become less tired, maybe you’ll be able to reason it out.

hmm… this is the source of my confusion, as i currently have the new building designer and i am using alpha 10 unstable… :confused:

this is why i wanted a screenshot, then i could see your building UI and all that…

click the circled button when replying to a comment to upload a photo

also, just encase you dont know, F12 is the default to take a screenshot with steam :blush: