Undeployable/unexisting items in town inventory


#1

Summary:
Three items that show up in the town inventory seem to be inaccessible, two cricket golems and a bronze shield to be exact. Neither of them shows up in chests nor on the ground in stockpiles or next to the hearth, people cannot equip the shield and the golems don’t show up in the placeable menu either, and I can’t sell them. I found a command to dump all inaccessible items on the ground next to the hearth, unknown command. Later found out that the command was removed and it’s supposed to automatically run when game loads, tried loading and saving a bunch of times, nothing happens at all.

Steps to reproduce:
No known way, the first golem I got from the first rabbit that pulls down the hood, I didn’t actually get anything and thought i just missed it or people didn’t actually haul it, eventually forgot about it. The second item is a bronze shield i crafted along with many more gear items, couldn’t tell when that happened, I just ended up missing a shield. Last item was the last golem, i undeployed one just to test, then got busy with combat, when I got back the golem was just missing. Next golem I undeployed behaved normally.

Expected Results:
The game should spawn unreacheable items next to the hearth when I load.

Actual Results:
The game doesn’t spawn anything when I reload.

Notes:

Attachments:

Version Number and Mods in use:
Stonehearth Desktop version 1.1.0, according to the actual file in my folder. No mods, totally vanilla, I didn’t even download any templates.

System Information:
I run a Windows 10 pc and purchased the game via steam, i have no idea what information could actually be helpful here so just ask if you need to know anything.


#2

Try using my Steam Workshop :: Town Inventory Tracker mod, which will cycle through selecting the items you click on in the town inventory. Even if the camera doesn’t indicate where they are, if they’re truly in limbo, they should be selected and then you can do other commands to them.


#3

Amazing mod, thank you, now I kinda see what happened. First of all:

This just made me feel kind of dumb... but secondly:


This is just dumb by itself, the golems were already placed and even if I undeploy them and set them in again more weird stuff happens so i'm going to avoid that. You were super helpful, do you per chance know how to sort of clean the game data so that the deployed golems count off of inventory? In any case thank you so much, still sort of a bug but not the way I thought.