Unbuilt structures

As seen in the picture, I have unbuilt structures which I guess is bugged… How can I make them reset?

I would try to replace them, but turn them around. They may be getting prevented by the two gold things you have in front.

Pause the game for a few seconds and if it doesn’t work save/reload the game.

Strange… Have you tried to build ladders to reach top of the fences so they can place the stone items, It may be to high for them to reach (weirdly). With the chairs, that also looks strange, Are you sure you crafted the right amount? If so, as asked above, Have you tried re-loading the game, sometimes an action can be forgotten until an save / reload.

Hope that helped.


Your builders can only reach items at foot level, so you will need to make a ladder there first.

Unfortunately, you can’t remove an item that was not placed yet… You need to wait for someone to place it, then you can ask someone to remove it.

can’t you use the “cancel task” button to remove the ghosts?

No, it only works to stop harvesting, like chopping trees, gathering bushes or mining rocks.

Actually you can. You just have to find the item that must be placed and you cancel the action by clicking once or twice on any arrow (green/red)

1 Like

Care to show a screenshot of it?

For me those green (move) and red (pickup) arrows only show for items that are already placed in the world, not the ones that are only a transparent plan to be placed, which makes me wait for them to place the item, and only them ask to remove, instead of canceling the placing.

if i understood @Powerclank correctly he meant if you find the yet to be placed items in your stockpiles… but i probably just totally misunderstood him.

I’m going to try that. Just a sec.

No, it didn’t work either. Clicking on the item in inventory just shows an option to place it down as a new item.

1 Like

That is what you want. Move the gold things to the side, then place ladders, your Stonehearth-ians will place what you want, then remove your ladder, then put the gold thing back in front.


That’s because you used the inventory. @8BitCrab was right : you need to find the item that’ll be moved to execute this task.

Can you post a screenshot then?

Cause that’s what I did that and it doesn’t work. I had only 1 chair in stockpile, I selected it and ordered to be placed somewhere near. Before one of the settlers got the chair from the stockpile, I re-selected it (from the stockpile), and no icons appeared… Only the same one to place item.

As you can see, I selected it from the stockpile, and it has no icon to remove the ghost. Only to place another one.

Oops you’re right. That only works with the red arrow “Undeploy” :confused: