UI Disappearing

Whenever my cursor hovers over an object or anything that is not the ground, the whole UI disappears. It even stays disappears if I click on something to select it.

Steps to reproduce:

  1. Boot up the game
  2. Use mouse
  3. UI Disappears everytime you hover over anything selectable

Expected Results:
UI not disappearing?

Actual Results:
UI disappears!

I have tried manually removing all things stonehearth related and reinstalling the game several times, also with AVG off.

I don’t think a screenshot of a game with no UI helps here? Or should be looking for somekind of log that could bring out the culprit

Version Number and Mods in use:
The SUper Unstable A16! 2924

System Information:
Windows Vista Home Premium 32x bit
Intel Core Duo 2.4Ghz
Geforce 9600 GT
3G ddr 2 ram (can’t recall mhz)
400 g HD, with 100 gigs free.

Since I haven’t found any similar problems on the forum regarding A16, is it because 32 bit OS or something?
I mean… The game is playable, but promoting and all menu things are pretty difficult to do.
The UI seems to exist even if has disappeared as I’ve managed to assign few crops to farm fields!

1 Like

I can confirm this bug. Can’t play A16 at the moment because of this bug, almost impossible to upgrade hearthlings etc.

I can still play A15 though

Yup have the same problem still waiting for a update for this for the meantime time to play alpha 15 T_T

again with me too. sorry first time bugger, but here my code.

when ever anything is selected, the UI disappears. click away from the item, and the UI appears. i can upgrade 1 hearthling through the character menu, but when clicking on a second name onwards, UI disappears.


@Kevintjee @KiotheCloud_Survivor and @Chad_McAuliffe are you three also running a 32-bit OS?

sorry no, i’m running 64 bit

Hello all,

This is almost certainly due to older graphics card drivers. Can you go to Some Technical Stuff – Stonehearth, and in the section on ‘updating your drivers’, follow the steps listed for your graphics card maker. And please let me know if that fixes your issue. Thanks!

Oh boy, I believe I need to try beta drivers in my case, I am running the latest Nvidia drivers for my ol’ Gforce 9600 GT

Well, if anything, it has been whole 7 monts since last clean reinstall of drivers, that might do it!

Hmm. @Haymaker, would you be okay to test out a custom .exe of Stonehearth I’ve compiled? I think I see a plausible candidate for a driver bug, and I have a workaround, but I have no means to test this. I’d give you a link to the .exe privately, and then you’d have to copy it to your existing Stonehearth directory, making a backup of the old one (just in case!)

I did just update my video card driver to it’s most recent driver. The UI problem is still occurring. I am running a Geforce GTX 260

Sure thing. I tried clean installation of latest drivers and the problem exist. Seeing my GPU is almost decade old, NVIDIA updates don’t really do much, but sometimes it can be just the thing.

And to rest of having same problems, but may fixed by some driver updating do it like this:

  1. Download the latest drivers
  2. Uninstall everything GPU (the drivers, PhysX, etc)
  3. Boot up in safe comp mode (just to make sure no program is interfering)
  4. run the installation as admin
  5. Reboot back to normal mode

EDIT: Incompetency with post format, so edited it around, wanted to adress the driver installation to readers, not to definately not owen wilson… and failed at it.

EDIT: Found a workaround
Enabling high quality graphics made the problem disappear, the downside is noticable FPS hit!

same i cant play A16 at the moment because of this bug :frowning:

Shameless self bump post because I have found a workaround that might work, I’ll state it again in a brand new reply too!

Enable high graphics mode in the settings, that makes the UI stay! Just makes playtime before inevident crash for me a bit harder not to mention FPS drop, but hey… Alteast i managed to see the fuzz about the new combat! I Like it


still no fix?i can’t play on a16

Have you tried enabling high graphics?

it works with highgraphs but my computer isn’t that good

Are you all on latest version (dev2960)?
Let’s ping @not_owen_wilson again.

Hi @Kirito_Kun! This should be fixed on the latest a16. If you are still experiencing the issue, can you post your stonehearth.log file? You can find your log file in C:\Program Files (x86)\Steam\steamapps\common\Stonehearth\ (for a steam install), or C:\Program Files (x86)\Stonehearth\ (for a humble install). Thanks!