Chasing vanishing UI (mods)

Hi, im new in Stonehearth, couldnt think of where to post this, so…

I’m having this strange issue with UI completely disappearing when i select or highlight any object or creature on the field.(when deselected, it shows again). both in windowed and fullscreen.
I have really fresh Win7x86, so im thinkin, maybe im missing something installed, for game to work propperly. Video drivers are ok.
Do i need anything aside from:

Hello @Evil_Grim, welcome to the forum :smiley:

I’ll page @not_owen_wilson for you. Which version of Stonehearth are you playing?
Which are your system specs (CPU, RAM, Graphic card…)?

Also, did you make sure to check your video drivers from your manufacturer’s website? Sometimes the auto-updaters are wrong / don’t detect correctly newer versions.

1 Like

it’s pretty old, dual core 2ghz, 4gb ram, GF9500.
i tried updating JRE\JDK, but still nothing.

Hmm it’s on the minimum’s but I’m not sure about the graphics card…
Don’t worry about JRE/JDK, it has nothing to do with Stonehearth, the game isn’t written in Java.
It uses Javascript for the UI, yes, but this is a different language than Java, and doesn’t require JRE/JDK.

I’m not hardware savvy so maybe @Albert or someone else from the team could tell if there’s a problem with the video card or if it’s a different problem. :sweat:

i mean, apart from fading UI it runs ok (well, slow, but ok). i remember where the buttons are, so its still playable…

If you post the stonehearth.log, we can see if anything strange is in there. Thanks!

sorry for not responding, i was kinda away. the problem solved, it was mods related issue.


No problem. Thanks for coming back to us, anyway! :slight_smile:

1 Like