UI Flashing [Save Included]


#1

Summary:
The daytime gathering UI flashes very quickly over the night time UI (with or without anything selected)

Steps to reproduce:

  1. Load save? Unsure of the trigger

Expected Results:
UI doesn’t flash and hurt my eyes

Actual Results:
UI flashes every 3-4 seconds all night long.

Notes:
Makes it hard to play at night :frowning:

Attachments:
Chunky save file link: https://drive.google.com/open?id=0B-yW4EBL-jH6ZkZqbDdUYmpPRFk

Version Number and Mods in use:
2924 A 16

System Information:
i7 4790k @ 4.5Ghz
Gigabyte R9 270 @ 1150/1575
16 GB (2x8) Corsair DDR3 @ 1866
1TB Segate Green (Game install location)
360GB Segate (C Drive)

— EDIT:

Thank you kind omni-crab! +edit for clarity and having an actual, valid processor type


Alpha 16 unstable: UI glitches
#2

Are you suing the latest drivers?
And try this, if it flashed, press F5 to reload the UI, maybe it helps …


#3

Tried both. That it works through a reloaded save shows plenty - it should be immediately noticeable upon loading my save.


#4

i have the same problem


#5

huh… i loaded up the provided save and waited 2 in-game days and nothing went wrong with the UI… :neutral_face:

not sure who to page for this kind of thing… @yshan?


#6

That’s interesting. I went so far as to check that save (reloading it fresh) before uploading and it immediately triggered the same issues.


#7

hmm… perhaps its your install is messed up and requires re-installing the game, or something to do with your game settings, or maybe even your graphics card… there’s a lot of different things that could be causing it, so i’m going to wait for some input from the team…


#8

They changed the renderer recently, so there might be issues (I guess @not_owen_wilson knows).
In fact, before, when I pressed AltGr key, I could see debug thingies, while now all the window gets yellow.

Also noticed some color change in models due to the distance / ambient fog, which I assume it’s done for performance or has to do with the graphic settings.

@Ztu, could you post your system specs too? Just to compare with @Aethrios.

It could be a case of outdate graphic drivers too, we always tell to check them through the manufacturer’s website instead of the auto-updater.


#9

Hi Aethrios,

Can you post your stonehearth.log file please? You can find it by doing the following:

– Right click Stonehearth in your Steam library
– Select ‘Properties’
– Select the ‘Local Files’ tab
– Select ‘Browse Local Files’

You’ll find stonehearth.log nestled among your local files.

Thanks!


#10

This is happening to me too.


#11

@not_owen_wilson Here you are! Hope it helps. As far as drivers and all the rest go, I’m up to date. I checked just a little while ago while going through a system rebuild, and checked again in light of this issue, so that’s all sorted.

stonehearth.log (3.4 MB)


#12

Hmm. Okay, those are definitely up-to-date drivers. Can you try turning on (or off) high-quality graphics (hit esc to bring up the menu, make sure you’re on the graphics tab, and then check/uncheck “enable high quality graphics”). Please let me know if this helps any. Thanks @Aethrios!


#13

After checking in I was playing for a bit, and didn’t notice the flashing UI (I had actually completely forgotten about the issue). Even after downloading and replaying the save I linked originally, I couldn’t replicate the issue. I don’t think I updated any drivers in the last five days, but I could be mistaken (there’s also the possibility of background windows updates; like I said, it was a system rebuild). I suppose for now my specific issue has been addressed, but I’m not sure if this is something that @ztu is still experiencing?

That said, I am still plagued by a lot of the lua runtime issues other users (myself included) have been reporting, but these are the joys of super-duper unstable builds!


#14

When i check high-quality graphics on the UI stops flashing but i will get 9 fps. And when i turn high-quality graphics off the UI starts to flash again, Does that change anything?

EDIT: Reinstalling stonehearth also doesnt work.


#15

Thanks for the feedback! I think I might have fixed this while fixing another bug. Would you be willing to test a custom stonehearth.exe build for me to see if it fixes the problem?


#16

That would be great thanks!


#17

And may i ask which other bug you have fixed?


#18

Summary:
The UI glitches
Steps to reproduce:

  1. Start up stonehearth alpha 16 unstable(steam)
  2. Start a new world
  3. UI starts to glitch

Expected Results:
UI Doesn’t glitch
Actual Results:
UI glitching
Notes:
This did not happen in alpha 15
Attachments:

Version Number and Mods in use:
Alpha 16 unstable (steam) No mods
System Information:


#19

This keeps happening when i restart the game.


#20

@Cube1 , is this the same bug that you talked about here: UI Flashing [Save Included] ?