Weird stuttering (disable ROG Gamefirst Service)

After the game was added to Steam I decided to try it again, but I’m receiving weird stutterings at random times. It doesn’t matter what graphics settings I have, same with every setting.

Video of it

I’m running the game on:
Intel i7-4720HQ (2,6GHz, turbo boost running on 3,4GHz while playing this)
GeForce GTX 980M (4GB)
16GB DDR3 1600 mem
SSD + 7200rpm HDD (game is on HDD)
Windows 10 Home x64

IT happens both on a14 and a15 with completely new worlds, no mods nothing

1 Like

hey there @kerts93, welcome to the discourse :smile:

does the stuttering/lag only happen at night?

if so, there are some problems with the lights that can cause lag at night, so try turning down/off the “maximum lights” and “shadow details” options in the menu and see if the helps.

i know its not a permanent solution but its a workaround until the team gets back to working on lights :slight_smile:

1 Like

thanks for the suggestion @8BitCrab but sadly it that’s not it. also happens on the day.

Like I said I tried turning everything to the lowest and to be sure after your suggestion turned max lights and shadow details to the lowest possible. No change at all, not even a slightest.

1 Like

hmm… i dont think i’ve seen reports of lag like this that wasn’t because of the night lights thing… :confounded:

guess i’ll page @Albert (one of the devs) to see if he has any ideas…

1 Like

@kerts93 - Thanks for posting the video. That helps a lot to narrow down the issue.

A few observations:

  1. The performance bar in the bottom right is mostly green, and you only have 7 hearthlings, so the game logic itself isn’t the bottleneck.

  2. It looks like the stonehearth process itself isn’t getting CPU cycles during the pauses. I would say this looks like memory being swapped to disk, but that doesn’t seem likely unless you’re running some big program in the background or have a messed up pagefile configuration.

  3. Can you put up the task manager and see which process is taking CPU cycles during the pauses?

If any other IT folks have ideas, please chime in!


Here you go @Albert

Game FPS is also over 70 all the time, here is a video with task manager and intel extreme tuning utility,which shows CPU usage, open also.

CPU isn’t even fully utilized and no special program popping up also (bandicam isn’t the cause also, because it’s the same even if it isn’t running).

At one point I thought it was caused be terrain/world changes building/destoying etc but it happens even if the heartlings are idle and completely unchanged world, although it happens less in that case.

1 Like

Ok, next step if you’re up for it.

  1. Get our debugtools from here (hit the Download ZIP button on the right):
    GitHub - stonehearth/debugtools: Stonehearth Debug Tools Mod

  2. Decompress the file and rename the folder from debugtools-master to debugtools

  3. Move the folder under the stonehearth_data\mods folder where all the mods live

  4. Run the game and hit F10 to show a bargraph of the client renderer. Take a video/screenshot of the freezing

  5. Also send us the stonehearth.log from the run

This should hopefully tell us where the problem is.


The tools start running but F10 doesn’t do anything (I know they are running because the extra icons appear on the top corner.
Here is the stonehearth.log: 2016-03-18-kerts93-stonehearth.log -

1 Like

Ah, add this line to your user_settings.json file:

"enable_debug_keys" : true

Remember to add a comma if it’s not the last item before a closing brace }


for reference, i have it directly under my user_id, so it looks something like this,

    "user_id" : "your user id",
    "enable_debug_keys" : true,
    "collect_analytics" : true,
    "alpha_welcome" : {
        "hide" : true
1 Like

Well i’ve seen this happen in my games also , with new ones as well as with older saves. Just not as big as yours, so much better playable. Just thought to my self it must be because its an alpha.

Ok. Nothing weird in the client profile.

The log shows that it took a long time to flush the streamer which is how the server process sends data to the client. We should check for anything that filters, monitors, or prioritizes network packets (including VPN) that is running which could be interfering with Stonehearth.

Your task manager shows ROG Gamefirst Service which has been known to cause lag spikes:

Can you disable the service and try again?


@Albert Thanks that actually solves the issue which is interesting.