Trying to destroy building after removing bed causes everything to

Yeah. I think it’s because I placed the buildings via template, then removed the beds at a later time and tried to remove the building. This happened.

Steps to reproduce:

  1. Make basic house from template.
  2. Remove beds.
  3. Remove house.

Expected Results:
The house would collapse like normal.

Actual Results:
This. The buildings lost half their walls, but kept the collapsing animation and the clouds went POOF POOF POOF repeatedly. It never went away. I didn’t catch the error message, and haven’t been able to replicate it, because I haven’t tried.

Maybe I’ll actually see it. It could be because it was built close to the water (3 tiles away). MUST EXPERIMENT.


Version Number and Mods in use:
dev-3349. No mods.

System Information:
Super fancy.

I’ve only ever had bugs like this in the older versions after designing too complex buildings for the engine and then trying to remove them. I’m sure the support team would appreciate an error log if you can manage to replicate the problem.

Hmm. It was a generic building template. I think it had something to do with all the stuff I had piled up around the building, but I haven’t been able to test it effectively yet. I wish I snagged the error message when it happened.