[Con] r153 - unable to upgrade beds from template buidings


#1

Bug:
When using template houses, unable to upgrade items inside. namely beds

Summary:
Build two multi person sleep houses from supplied template. once my carpenter could upgrade them told him to do so. he went, picked up the beds, and didn’t put them back after the upgrade. was also unable to place them back by hand.

Steps to reproduce:

  1. build house from template
  2. furnish house
  3. tell carpenter to upgrade beds
  4. carpenter upgrades beds and puts them in stock pile
  5. when the night comes
  6. everybody on the floor walk the dinosaur (well sleeps on the floor)

Expected Results:
carpenter goes gets bed, upgrades bed, returns bed. people sleep more comfy than i do.

Actual results:
Once beds are picked up they can not be upgraded and placed back. people sleep as comfy as i do.

Work around tried:
Placing the beds manually. unable to as they are slotted for mean beds

Suggestion?
With templates, during building, have specific id’s. once built use generic id’s.
If building - use item (mean bed)
elif - use item from family (beds)

Link to image:
imgur.com/NDEWtWR
can’t do a proper link either
Mod edit:


#2

I can confirm this. Any time you undeploy or move an item from a template, it always shows up as a “ghost” when you click the “Build & Design” button and you can’t place anything there anymore.

For example, I built this wall and saved it as a template, then moved the lantern from the left to the right. Now it’s stuck as a ghost on the left and I can’t do anything with that spot.


#3

I have noticed this too. I tried to remove the bed from the template and add them manually after the construction, still the problem remains. If you put something (a bed, at least) inside an already built house, it will leave a unremovable ghost even after you remove/move the item.


#4

I’ll just go ahead and confirm this as well.

If a Bed is removed after building for whatever reason from a templated house, that spot will forever be blocked by a “Ghost” bed. I have not tried for other items.


#5

You can actually fix this quite easily by going back to the building design template for that building. Here is a video showing how to do this.


#6

Supposedly fixed in 156! We need confirmation, stat!


#7

Confirmed fixed in r156 both when manually removing and when allowing carpenter to remove as part of an upgrade recipe.


#8

Still seems hit and miss on this. I’ve had dinning halls allow me to upgrade the chairs through some of it, then stop half way through. The result tends to be ghosted furniture and not even being able to put a normal chair back in there. Sometimes undeploying a chair will result in a working picking it up and putting it in a ghost slot.


#9

I have encountered the same result. I got to upgrade the beds, and once I get the comfy beds made, I cannot place them where the mean beds were because of the ghost. I tried to upload a SS of the issue, but “New users cannot upload photos.”