Latest unstable - cant put beds etc into buildings


i use the latest “builder” as the old one wont work in unstable. ive removed beds to “upgrade them” now I cant put anything back in any building, including the workshop items.

is there an upgrade beds / furniture function im missing, or do i need to delete the house to put new beds in …

Currently it’s better to design a house empty (and save it that way as template!) and put the items in later, because the template wants to remember things like beds and chairs after finishing, while it would be much more Conveniant to actually forget about them

1 Like

@paul_summery, you should be able to place new items in finished buildings using the Placement menu.

Edit: unless it’s throwing errors like with the templates :thinking:

I can’t seem to place objects into buildings either, except in the locations I can see through a window. There is a visual flicker when I move objects around the placement grid since it’s a snowy day as well. Also I’m having trouble right click hold rotating my view if my cursor is over a building. I’m pretty sure they’re related.

The only spot I can put the jar is visible from the window.

1 Like

ive had that once( the can only place through a window-bug), was a long time ago though.
does it help if you toggle the walls all the way down? (and up and then down again, possibly re load the save… that kinda stuff?)

Yeah I had that error before long ago as well. I did go to the other views and it was all the same. I’ll try reloading and then a new game. Also this holds for all of my buildings.

Seems there were some regressions on the new builder in the latest release, sorry about that. :disappointed_relieved:
We’re working on it.


atm, from what i’ve figured out, it’s to do with stuff being in the way, the view options take away the walls from vision, but placing stuff through them is impossible, in a big enough house if you mash your camera within the walls etc, you can manage to place something, also on open-sided houses (like the downstairs of the blacksmith, or the shed of the carpenter, if you look from the front where there is no wall obscuring view, you can place stuff

another issue, an existing save file of mine, has a carpenters hut and has the normal bed and drawer, but they were invisible everywhere but the builders menu, but i did see hearthlings sleep on the bed (and it didnt look see-through, as if it’s yet to be placed) i tried moving them in the build menu, they do this fine, and it appears while a hearthling holds the item in question, but when they place it back down it turns invisible, and impassable.

on a sidenote, i cant turn the camera (right mousebutton) while hovering over something designated as a building (so not just actual buildings, roads too) it simply doesnt register the rightclick)

but this is inconsistant, this seems to only be the case when im trying to place something

does it look savefile based? so if you make a new game does it to it too?

Have this problem in a new game started after last nights patch, also wall supply shelves above floor supply shelves are not being stocked. Yes I’m sure they are low enough.

Clean game no mods except for debugtools, On trying to place an object in the world I got this engine error. Still can’t place without my cursor selecting through a window or at least not through a wall.

release-851 (x64)

…ehearth/services/client/build_editor/item_placer.lua:172: attempt to index local ‘entity’ (a nil value)
stack traceback:
[C]: ?
…ehearth/services/client/build_editor/item_placer.lua:172: in function ‘_location_filter’
…ehearth/services/client/build_editor/item_placer.lua:71: in function ‘_location_filter_fn’
…ces/client/selection/entity_or_location_selector.lua:224: in function ‘filter_fn’
…nehearth/services/client/selection/selector_util.lua:23: in function ‘get_selected_brick’
…ces/client/selection/entity_or_location_selector.lua:211: in function ‘_get_selected_brick’
…ces/client/selection/entity_or_location_selector.lua:283: in function ‘_on_mouse_event’
…ces/client/selection/entity_or_location_selector.lua:451: in function ‘go’
…ehearth/services/client/build_editor/item_placer.lua:85: in function ‘go’
…tonehearth/call_handlers/place_item_call_handler.lua:24: in function <…tonehearth/call_handlers/place_item_call_handler.lua:20>

Workaround: Place it outside the building, then let it move. Worked for me.

Can’t seem to do that either.