Trapper zone drops not hauled to storage

I’ve posted a similar report on the Steam Bug report threads. To summarise:
My trapper zones are covered in drops but neither my trapper nor my workers will actually haul the bug meat, jerky or any other trap zone drops. I can’t even mark them as loot to be collected. This has become an issue since the latest ACE “drinking update” as far as I can tell.

I tried reducing the zones to just one and then removing them completely, but the drops are still being ignored. The trapper will then go haul different items and harvest plants instead.
As a result, the meat and jerky don’t count towards my daily update.
I’ve even tried other fixes that might’ve worked for others in older versions:

  • I’ve demoted the trapper and promoted them again,
  • cut down all trees between zone and stockpile,
  • made sure there’s room in stockpile
  • have a crafter use that “missing” resource ( e.g. a chef making the Tasty Bug Stew. I’ve no bug meat in storage, but there’s tonnes around the zone)
  • started a new game with new characters.

The new save seemed to have fixt it for a time, but the trapper wasn’t the one picking up the food- the potter was (until they got busy crafting)

Steps to reproduce:

  1. Promote a trapper
  2. Pick a trapping zone
  3. Have other resources besides food be harvested

Expected Results:
The drops from the trapper zone will be picked up by the trapper or workers and moved to storage (stockpile, chests etc.).

Actual Results:
Once more things need to be done around the town, all characters will prioritise those actions instead of moving the drops (including food) from the trapper zone into storage.

The trapper never hauls his drops to storage. Instead only surveys the field and checks traps, then moves on to harvest or cut trees and other plants that have been marked.

Version Number and Mods in use:
Steam version-
Mods from Steam Workshop
ACE Pre-Release 0.9.4 - “The Drinking Update”
- various building templates
- Fisher Job + Archipelago Biome
- Age of Giant - Piles
- Seeds for All [Fixed!]
System Information:

not a bug just how the game works
it should be collected eventually
a quick fix is to have some dedicated haulers and enough storagespace

The problem as you’ve described it is that your hearthlings’ AI is not selecting hauling tasks, for which there are many possible reasons (it shouldn’t have anything to do with the trapper and their drops, but should also affect items dropped from chopping trees, mining, etc. at similar distances from stockpiles). You specified you’re using version 0.9.4 of ACE and not the patch that removes a lot of pathfinding lag that was accidentally added for hearthlings considering drinking from natural water sources. I’m going to guess that your stockpiles are far enough away from your trapping zones that the hearthlings are having trouble with their pathfinding for hauling and prioritizing other simpler/closer tasks. I recommend installing the update and seeing if that helps.

You were right. For some reason Steam didn’t automatically update my ACE so I unsubscribed and re-subscribed to it. I didn’t even realise there’d been an update to 0.9.1. I then started a new game and that seemed to fix it as long as there’s not much else that needs restocking.
The solution does seem to be what you and [nightlancer] said, a dedicated hauler and a stockpile nearby (i placed a chest next to the zone)