Traders don't see items in crates

//edit: I think I made a mistake myself somewhere, since I can’t replicate the issue anymore.

Hi Folks! Been a while since I played Stonehearth, the new features all looked so cute I just had to play another full weekend of this. :’)
Now everything is just so much smoother than a year ago. Kudos Radiant for the progress!

The reason for this bug report however, is that using crates predominantly to store items poses an issue for certain mechanics in game. A lot of these have also been fixed, seemingly, but traders (If you give x, I’ll give you y in return, sort of thing) don’t seem to be aware of the items in crates and will pass their offer when they return due to this.

Steps to reproduce:

  1. Play for a while until a ‘barter trader’ appears
  2. Accept the trade
  3. Store the items required for barter in crates, and wait until he/she returns.

Expected Results:
Trade is made, items subtracted from crates, gained items appear at the banner.

Actual Results:
Trader doesn’t see the items in the crates, and passes on the deal.

Version Number and Mods in use:
Alpha 20, release 701 x64
Zero mods!

System Information:
GTX 970, i7 3770K, 16GB RAM, Some Gigabyte motherboard. Don’t think it’s relevant for this issue.

Define “crates”.

I’ve stored my stuff in stone chests, and I can trade just fine. Are you sure your hearthlings didn’t just use up one of the items while you weren’t looking?

The in-game items ‘Large Crate’. I’m not using the stone ones.
And nope, I can see the items I need to trade in both the ‘inventory’ in the ‘Town Overview’ as well as in the individual crate they’re stored in.

Could you add some screenshots?
I can not confirm this behavior nor I can deny it but as Ascendancy I am using mostly large crates and as Rayya I use everything and I did not have had this problem at all.

The moment at which it happened already passed, but I’ll try to recreate it in my current game, taking saves at moments before the trader returns and such. Back later.

Well. Nevermind. xD
It worked this time. Must be my own error somewhere, or an isolated incident.

If you get this bug again, pause game and save :slight_smile:
Oh and make some screenshots.

I saw another bug thread like this where the issue was solved. Maybe it was fixed in the last update which would explain why you were having issues then couldn’t replicate it.

Hi! No, I think I made a mistake myself. Looking at the Town’s whole inventory includes those items that are already placed as physical objects such as chairs, tables, dressers, and even bundles of wood and stone and such. So I think I had júst about too few Simple Wooden Chairs actually sitting as deployable items in Crates. I haven’t updated in between it not working and working, anyway. :wink: