Greedy Crates Don't Want To Share

Some placable items stored in crates don’t show up properly.

Steps to reproduce:

  1. Make something.
  2. Store it in crate.
  3. Try to place thing.

Expected Results:
Thing is shown as being there.

Actual Results:
Specifically look at the number of tree saplings.

Version Number and Mods in use:
Develop-2860 (x64)

1 Like

Ah, the old “I can’t place something that’s in a crate” thing, but for real this time - it actually won’t show up in the place object menu that you actually know how to find.

The other thread I found on not placing items was just a problem with Hearthlings placing them, not them not showing up in the menu, and only possibly related to crates.

So I’m pretty sure this should remain as its own thread.

Fun addition. If you restart the save file, it will show the correct amount in there, until you place one and they all go away.

1 Like

I ran into this as well, but for me, a workaround ended up being to tell the crate not to store whatever type of item is causing the issue - that seems to cause the hearthlings to go empty it and go, OH HEY we need to put this somewhere! So they do.

I sort everything, So those crates were only meant for plants, which saplings are included in. Now that being said, I just moved them to a storage square, and they’re still not shown in the placement menu, but I can manually select them and place them.

1 Like

Can you please upload that save? It will help in looking into this issue.
Thanks for reporting it!

1 Like

Save Game File

Try this one. I believe it’s the save when this was happening.

I believe I’m having this or a similar issue and I kind of wonder if this issue isn’t the same basic problem Using Pots as Food Storage - Not refilling after hitting limit - and that is that storage items just don’t work correctly.

I started a game the day before 2865 hit and started a new one after it and both times crates just don’t work. In both cases I tried switching from an initial general stockpile to stacked crates for more specific storage, and what ends up happening is they’ll load up the crates just fine, but they just will not consistently take stuff out of crates.

So I have hearthlings not eating for an entire day and getting a morale hit even though my population is growing I have 100’s of units of food. Crafters are not grabbing mats from crates right next to them and will not craft because they think they have no mats.

I don’t know if it’s a situation where they take one item out and the crate locks up like described in that other thread or what. I’ve been trying to watch (I’m a developer and debug plenty myself and can usually make some hypothesis but have nothing yet for this) but there’s usually so much going on it’s hard to isolate. What I do see is my crafters not crafting when I have tons of mats in crates or only crafting when they can grab stuff off the ground.

Once I got all my “inventory” out of crates and back into regular stockpiles all my crafters got busy just fine.

It’s also probably worth mentioning that the game can see my resources but the hearthlings cannot. What I mean is that if I want to queue up copper bars for my blacksmith, I can see that I have 15 copper ore via the forge queue and can queue up bars without issue, but then my smith won’t actually smelt the bars because the ore is in crates.

I’ve also had mixed results getting hearthlings to empty the borked crates (in my game last night I went back to regular stockpiles rather than give up completely). In some cases they unloaded the crates just fine with the crates set to “nothing” but in other cases they would not unload crates set to nothing. Fiddling with the settings and picking something like the nonexistent ranged weapons would cause them to finally unload the crate (or as others have said, switching what’s stored works but I wanted the crates emptied so I could unplace and sell them).

Side note - I wish stockpiles/storage started off set to “nothing” rather than “all” because my people are like ninjas with putting stuff in newly placed stockpiles or crates even when I watch like a hawk and change the settings right away - inevitably whoever is picking up anything from anywhere will bring it to the new 'pile/crate, drop stuff in it, and immediately grab it and move it elsewhere due to me having changed the settings. Being able to set priority on stockpiles would be huge.

Lastly, and trivially, the animals that befriend your hearthlings seem to eat stuff off the ground (like freshly harvested veggies) but they won’t eat out of crates either. It’s kind of sad to see them running around hungry for days at a time. I ended up making a small stockpile between my farms and crates to try to get some stuff on the ground for them as I had left my food in crates (after uncrating everything else) until I noticed morale hits for not eating for a day - and that’s when I saved and quit late last night.

PS - couldn’t upload my save since I’m a “new user” (and as an aside it took 5+ hours for the confirmation email to get to me when I signed up)

1 Like

Refer to this;

Check gameplay tab in settings. There’s an option for that.


I tried adding some crates back in my game without stacking them and same deal. They’ll grab an item maybe, but they stop and then won’t use the crate. Had a crate of wood right next to my carpenter and he was walking quite some ways to get wood from my smith’s wood pile instead.

I also had a few crates I just couldn’t unload no matter what I did that had food in them. Ended up just letting it rot so I could remove the crates.

Do crates work for some people? /shrug There doesn’t seem to be that much discussion of them not working so maybe I just need a reinstall or something.

Dunno if reinstalling did the trick or if it was 2867 but I think my people are using crates now. I didn’t “test” for too long yet so I’m not 100% convinced yet but did see my carpenter pull wood from the same crate several times - which wasn’t happening before.

i play on the stable branch (a14) and i dont have this problem. all my crafters have their crate and use them properly so i dont think the release changed something :stuck_out_tongue:

I’m on dev/unstable branch build 2867 and thought reinstalling had cured this, but alas, no. I’ve attached a save where all of my crafters are queued up with lots of mats, but those mats are in crates, and they won’t craft, they’ll all hauling. If I disable hauling/mining for them, they go rest by the fire.

The carpenter is getting some work done - because he’s walking 100 blocks away to get freshly chopped wood instead of using the wood in the crate 2 blocks away.

Note that save/reload will cure this for a short while but they stop crafting after they make an item or (6.2 MB)

The only thing I’m doing that could be questionable is I’m stacking crates and setting them in groups, so they end up 2x2x2 blocks of large crates. My people have no problem loading them up this way though, and when I force them to unload them (or try, mixed results with that) they can usually clear them out.

1 Like

Crates have been working fine for me in 2871 even stacked 2x2x2. Again, I wonder if I had the issue fixed by this:

Fix for full storage containers not being reconsidered when an item is taken out, which means the containers are never refilled after item is taken out.

…but it doesn’t fully fit. I tend to have some crafters put finished goods in crates with mats - so smith takes ores from and puts bars back into the same crates and I could see how the issue that was fixed could cause that to stall. Same with herbalist and weaver.

But with my carpenter I don’t put the finished goods in crate, it’s only ever just wood going thru those crates, and while it’s working fine now, previously the carpenter would walk rather than use nearby.

Anyways - mercifully the crates are working now.