Town progression not triggered

I might have… um… lost… the hearth quest. I did not notice it has not triggered and now I’m stuck. Do you just left click the dot in the campaign browser? Because nothing’s happening.

I am also having this problem (Alpha 24.10); mostly in my recent attempts to start a map with Rayya’s Children! (Trying to unlock all those recipes!)

I’ve tried starting a few new games with saved/embarked hearthlings from previous maps, and only just now tried a brand new map with brand new hearthlings (I thought that perhaps my carried over wealth and even perhaps having the three banner shreds might be interfering), but that doesn’t seem to help.

Net Value in the two games with saved embarked hearthlings were at 20,000+ Net Worth, (new map is currently at 3000) and seemed to get stuck just after the “food donation” (that happens after I choose my banner). The hearth upgrade quest just doesn’t show up for me :frowning:

1 Like

If either of you could upload a save with the problem, it may help us find the cause.

Hopefully I did this right!
Here’s my two saves/maps:

With embarked hearthlings

and with my new hearthlings

Yes! It’s after the food donation and it’s Rayyas children with re-embarked hearthlings! We have a pattern, ladies and gentlemen!

Here’s mine. It’s a town started in r-841 and I’m pretty positive it did not trigger back then. I just updated to r-843 and the quest is still missing. Triggering manually is not responsive.

FoodDonation.rar (5.2 MB)

Thank you both! These should be very helpful. I’ll take a look at them when I have a little less on my plate.


Having the same issue. Mine is also after the food donation and it’s Rayyas children with re-embarked hearthlings.
But is there a way to manually trigger the next quest, for example in the java console?

Thanks for the saves! This should be fixed in the next release, although it won’t fix existing savegames.