Ignoring quest dialogue kills town progression?

i was just watching @Banto 's stream and found out a silly thing:

in data/gm/etc can blcok your save from continuing the entire town progression if you ignore the message and dont click it at all. it has a sort of time-out i noticed in the code making it go away. but because its away and you dont click it the edge in/out stuff doesnt seem to continue. seems like an important bug? @Relyss ?

any idea to manually solve this?

1 Like

I took a quick look into my own Let’s Play world, and came to realise I may have a similar issue, being stuck in a Tier 2 town.

Luckily, Radiant should already have this save-file, as it’s the city of Stilton I posted for them to check a few things xD

Are save files saved in plain text for quests? Maybe we could manually edit them to go to a stable point? Or is there like a reset quest button or command?

Seems to be a .bin file… no clue how to read those

My stream should be studied to fix stuff it seems :wink: hehe

1 Like

yeah noticed that too, tried renaming it to zip and tried unzipping, no jaz. and its 33mb so it would kill any text editor trying to open it, so probably not in anything like normal readable text

fixing it would have to be done from in the game. tried looking for console commands, couldnt find a list.

Save file for this one if devs wanna take a look at it

@Relyss is the quest issue known to you guys?

In the past there were some bugs related to the food donation encounter, but they should be already fixed.

I’m taking a look at Banto’s savefile (the Stilton savefile I have already had finished tier 3).

Looking in SHED, the food donation doesn’t seem to block the progress of the campaign though.

Or do you mean a different encounter? Is it for ascendancy or for another faction?

@Wouter_Sikkema, I believe this is caused by the way you have setup the campaign for your Nordlings:

I’ve tried to reproduce the scenario with Ascendancy, and the timer for the next encounter starts in parallel with the food donation, so there’s no problem even if you forget to click that dialog.

Since Banto is using your mod.


ah, i must have copied this stuff off before you guys fixed it then (its an adjusted ascendency)

ill compare the files step by step to find the differences then :stuck_out_tongue: (did not spot any differenes first time around)

edit: yep i see it now, -fiddles with it and hopes it will restore @Banto 's mid save quest :stuck_out_tongue:

thanks @Relyss !


I’d tried was just casually playing the game and then noticed that im way far into everything and have not gotten the opportunity to upgrade my town past the first upgrade. This might be a bug but idk? Either way does anyone know a command to manually upgrade my town?

i know how to do it with the debug tools, there is a sort of questline-viewer, if you find the town progression one you can manually trigger it.

but it may have to do with the actual amount of gold you have stored, i think there was a minimum amount you needed before it would trigger.
(so you have a special hearth, but no shrine, correct?)

With the debug tool mod activated, open console with Ctrl+C, and type increase_city_tier


I only have the banner and i tried the questline viewer and triggered the thing and tried to reset the town progression but I only got a bug.

Still doesn’t fix my problem. I increased the city tier but nothing came up and i couldn’t upgrade and get my hearth, I still just only have the 1st tier benefits.

The command I gave do just that. If you want the progressions/events, you need to follow the campaign. That said, it is controlled by the kingdom, so if you have a modded one, it may not even have those events.

So, disable my mods? Only mods i had were better storage, dense fields, box commands, auto harvest and ballista mod.

Could there possibly be a command to manually reembark because it may just be a problem with the save and if I start a new one then stuff might be working again

no its only a problem if you play as a modded kingdom (norselings, romans, nordlings, you name it)