Stonehearth World Creation Error (old drivers)

I just bought this game so there are no saved games.


This is the error code that I receive before the game quits.

Laptop Sony Vaio
2nd generation Intel® Core™ processor family DRAM controller

There are no available updates for my driver.

Please help!

That’s an error related to the graphics driver. Can you post your stonehearth.log file?

(You can find it in the same folder where stonehearth is installed. From Steam, right click Stonehearth in your library and select Properties -> Local Files -> Browse Local Files)

Hello! Thank you for helping.

I did as you said but did not see a log file? Is it in another folder?

Nevermind. Got it. But it says new users cannot upload attachments?

I just updated your user status. Try again?

stonehearth.log (11.6 KB)

Yeah, the drivers are 4 years old and have a bug that causes the crash.

Have you tried updating them from here?:

Or are these custom drivers that have to be updated from Sony?

I updated from that site this morning after the first crash and still no results.

Still getting Assertaion fail
gl_framebuffer ihome\root\SH-OB-BUILD\stonehearth\source\horde3d\Source\Horde3DEngine\egRendererBase.cpp:1266)

Does the laptop have another graphics chip (AMD or NVIDIA)? Otherwise you might be out of luck if they stopped updating those drivers.

I guess that’s it for the laptop. oh well. I’m not playing on the desktop because the game lags too much. Do you have any solutions?

Dell AMD Athlon™ ii x2 240
ATI Radeon HD 3200
Windows 7
64 bit

That desktop is also just below minimum spec. Have you tried turning down all the graphics settings?

Yes I have and it doesn’t help much so I’ll bear it until I can buy a new desktop.

Thanks for your help Albert

No problem. Happy to help!