GL_FRAMEBUFFER error in (r27) build


#1

Hello one and all,

In looking about, I noticed that there was a bit of a lack now in a main Bug or Error reporting thread here in the Support forum, though there are quite a few independent threads about, So, I am adding myself to the group in hopes that a fix can be found for what I have come across.
Using Steam, I downloaded Stonehearth, updated to the latest patch, and was FINALLY able to play the game on my laptop, rather than having to use a more inconvenient desktop in another room.
Everything was working fine much to my excitement and suspense, through the main menu, through the clicking of the new world button, and through the majority of the loading of a new world…
when… all of a sudden…
I was hit with the malignant error report! Gasping heard around the world, I know.

The error message read, at the top bar “Stonehearth Assertion Failed” while in the actual error message it reported, "status == GL_FRAMEBUFFER_COMPLETE_EXT"
Clicking ok, the game crashed and left me to the brink of tears and a great gnashing of teeth in frustrated early-adulthood angst. I hope that a fix for this can be found, and I look forward to hearing them.
My specs are as follows:
HP Pavilion dv6 Notebook
i3 Intel Core @ 2.10 GHz
6 Gigs of RAM
64 bit Windows 7 Home Edition


Can you all help me identify whats wrong?
Can you all help me identify whats wrong?
#2

Mm… I think I’ve seen your bug somewhere before… Have you executed again the game? I remember on r22 the first time I run the game it crashed, but probably was because I forgot to set my screen’s resolution on the user_settings.json file. After I changed that, I was able to run the game normally.


#4

@GeorgeCrecy I’ve deleted your post as I’m unsure if showing your user_id can potentially result in anything negative! I’m probably being over-cautious but I’ll get some official word on whether we should avoid displaying that.

The reason the settings haven’t changed I think is because the game hasn’t launched.

If you try to edit the stonehearth.JSON file rather than the user_settings.josn you might have better luck?


#5

I thank you for considering that Geoffers, I did not think of the possibility it might be used for ill.
In any case, I certainly did have more luck in going after the stonehearth.json file.
I do wonder though what the optimum numbers are to put for shadow resolution (currently listed as 2048), and screen width and height (1920 and 1080 respectively). I am guessing I change the latter to my screen resolution, and change the shadows resolution to be the same as my screen width, if I change it at all?

EDIT: I made a backup of the file and made the necessary changes. Everything still worked fine up until the world was almost done loading, where it made the same GL_FRAMEBUFFER crash. I neglected to mention that after closing that error message, another pops up about Microsoft Runtime, where the game requested to be closed in an “unusual” manner. Put quotes on that as that was the wording used: Unusual.


#7

Yer you’ll want to change the resolution to fit your screen resolution.

Try these as well: (totally didn’t steal these from @not_owen_wilson)

set “msaa_samples” to 0 (to turn off anti-aliasing)

turn down “shadow_resolution” to 1024,

turn off shadows completely (“enable_shadows” to false),

and turn off vsync (“enable_vsync” to ‘false’).


#8

Alright, I made those changes, but I have still gotten the same error message. I will say this about my computer, it can be very stubborn when it doesn’t want something to work.
As a more in depth mentioning of the other error window, here is the second one that pops up:
In the window bar: Microsoft Visual C++ Runtime Library
Error Message: Runtime Error!
Program: C:/…
This application has requested Runtime to terminate it in an unusual way. Please contact the application’s support team for more information.

Consider the support team… contacted…


#9

What graphics card are you running?


#10

this error is fairly “common”, and every time I see it, I forget where to find the corresponding threads! le sigh


#11

Oh, Intel. Why don’t you like framebuffers?

This is a particularly stubborn bug that only seems to hit a certain kind of Intel GPU. Does your notebook have a discrete GPU? Most notebooks running switchable GPUs allow you to launch an application in ‘performance’ mode or ‘energy-saving’ mode, so if that’s the case with your setup, you might be able to try running Stonehearth with the ‘performance’ GPU (probably an AMD, maybe an Intel card.) To do this, usually, you would right click the Stonehearth desktop icon, and the pop-up menu will have some manner of ‘launch in performance mode’, or something vaguely like that.


#12

of course, onboard intel graphics sets … I knew this sounded familiar…

who needs short term memory anyway? :tongue:


#13

If it’s any consolation before I told it to use the dedicated graphics it was using the intel HD 4600 and worked fine!


#14

Finally getting back to you, been a little busy:
My lovely computer uses both the onboard Intel graphics card, as well as a Radeon HD 6490M.


#15

well, not simultaneously… at least, not for gaming/SH (someone more graphically inclined, please tell me im correct)…


#16

This was my thoughts as well.

Have you tried getting the game to run on the Radeon card? You might be able to run it then?


#17

Unfortunately, I am not given the option of which to run the game on. My one idea would be to disable the Intel graphics card in Device Manager, though I am not positive that would go well, as there might be things which are dependent on it running. In any case, I am able to play other, even more graphic-inducing games without much of a problem.


#18

i know i have two cards in my machine (non-SLI) as they are split between 4 monitors… i dont recall being able to manually control what works for a particular card, but my best guess would be, disabling the onboard graphics would simply for all applications to utilize your Radeon card…

again, can someone more enlightened in this arena shed some light? @not_owen_wilson? :smile:


#19

Edit: I’m an idiot and didn’t check the first post.

I think my old laptop was the same/ similar model, different specs … and thinking back I had difficulty trying to get the Radeon card to be used …

I am seriously tired though so, this could be absolute gibberish.


#20

This stuff often…doesn’t work, or doesn’t work the way you would expect it to :frowning:

You could try to create an entry in the “Switchable Graphics” section of your Catalyst Control Center, which (in theory) will force Stonehearth to be run by the Radeon. See http://h10025.www1.hp.com/ewfrf/wc/document?docname=c03048374&cc=us&dlc=en&lc=en

There’ll probably be a setting in your bios for ‘graphics switching’, or some such. Turning off graphics switching will likely force the Radeon card to always be selected. Be careful when tinkering with your bios!

Otherwise, I’ll be starting work on getting Stonehearth to automatically select the discrete (fast) GPU in a laptop system, so this’ll likely be in in a week or two.


#21

see kids? it pays to be smarte…

you would probably earn a solid place on a few new Christmas card lists… :+1:


#22

Erm, @GeorgeCrecy, it looks like you’ll have to change the BIOS settings manually to get this off the Intel card: http://h10025.www1.hp.com/ewfrf/wc/document?docname=c02948560&cc=us&dlc=en&lc=en .