GL_FRAMEBUFFER error in (r27) build

Okay, seriously, that’s six different kinds of suck. Like, what do they expect me to do, pwn all AMD-based laptops and flash their BIOSes, just so there’s a hope in hell an average user will be able to get a decent framerate? OTOH, I guess that means I could ask the NSA for assistance…

1 Like

sooo, thats not an option on the table then?

ask, and ye shall receive…

I appreciate all the help, though I am sorry to bother one of the team members themselves with my small dilemma. But, by the sound of it I am not the only one suffering from a lack of Stonehearth because of this. But I will try your suggestion @not_owen_wilson, and I appreciate your esteemed help regardless.

2 Likes

best of luck! :+1:

let us know how you progress… perhaps we can add something like this to the workarounds thread…

My thoughts exactly. This seems to cover at least all the HP Pavilion class notebooks mentioned in the link, and maybe more. More internet searching reveals the anguish of other Pavilion owners, some that don’t even get a BIOS setting to change.

Suddenly, your quasi-omnipresence makes a lot more sense… :slight_smile:

2 Likes

Not sure if mistake part of joke, or just accidentally funny…

it was intentional… and funny… or, as I like to call it, intentionally funny… :smile:

1 Like

I have aquired a more modern computer with these specs:
Processor: Intel E5200 dualcore 2.5 GHz
RAM: 4GB
Hard Drive: 500GB
integrated graphics
OS: win7 home premium 64bit

but everytime i launch from steam or humble bundle version (all up to date) this little jerk pops up, and i have no clue how to work around, can someone help?

@Cannon0006, i’ve merged your thread here, as it seems you may be suffering from the same intel-based issue…

take a look at @not_owen_wilson’s post in this thread (re-posted below), and see if this helps you…

Can you tell me what kind of graphics card you have? (On Windows 7, here’s how to do that.)

Intel issue, likely, but the framebuffer issue only seems to strike after the world has loaded, so this might be something else…

roger that… apologies on the merge, as you were responding! :wink:

its an Intel® GMA 3100 integrated card, not fancy, but it runs things like kerbal space program without issue

Hmm. I think I know what this is–Stonehearth is a little overly-aggressive about the kind of graphics functionality it requires (a legacy from the rendering engine we’re building on), so right now it bails on some cards that it could otherwise run on. I’ve been meaning to fix this, but hadn’t had the time. I’ll try to get a fix in soon, hopefully for next week.

2 Likes

Unfortunately, I have some bad news to report myself. In trying to reach the BIOS of my laptop, I did get to it. However, it is one of the worst BIOS’ I have ever seen, giving me two options: to choose which operating system I want with a whopping one choice, and to change start-up procedures.
Beyond this little hiccup, I did manage to figure out after exploring a little in the link you sent me on how to change my graphics card switching settings. I configured Stonehearth specifically to be used by my Radeon rather than the Intel card. I started up the game, and attempted to start a new world…

…and now it works! It is incredibly laggy for some reason, though I did set the graphics settings as low as they can be atm. So to replicate, right click the desktop, and the second option from the top should be “configure switchable graphics,” though this might be different depending on the system and the person’s respective graphics cards. In the window that pops up, go down to where it says to find your application, click the browse button, and find the Stonehearth.exe wherever you have it installed in your system.
The browse window will close, and if you click the far right text, you can set it to “High Performance” or “Power Savings.” Go with the former.
Now run Stonehearth, making sure that VSync is enabled in settings, as it ended up putting up an error 1/3rd the way through world generation when it was not.

I have not tried this with the graphics settings higher up, as the game is very laggy is as, but at least it works now!

EDIT: Here is the link to where I found out how to get to the switchable graphics menu. Scroll down to the second bolded area which says “Determine if your computer has switchable graphics,” and click the first plus sign, which will expand, with pictures, to the more formal how-to.

EDIT 2: Sorry @SteveAdamo and @Geoffers747, this is the link I was talking about:
http://h10025.www1.hp.com/ewfrf/wc/document?docname=c02731962&lc=en&cc=us&dlc=en#N82

2 Likes

excellent! thanks for the follow up, and the steps you used to (partially) remedy your situation…

and it might just be my phone, but I’m not seeing the link you mention… :cry:

1 Like

I knew there was something I needed to comment in this thread about!

@GeorgeCrecy you don’t appear to have provided a link, unless of course it was a deliberate attempt to destroy people’s hopes who might be experiencing a similar situation, in which case, well played.

1 Like

Yay!

Boo!

…huh? Is this consistent (as in, you’ve run it multiple times without vsync on, and it crashes during world generation?) We’re not even rendering the world when we’re building it, so this might be just a big coincidence (but still sucks that you saw a crash during world generation. Sigh…) You should try it once or twice without vsync, just to see if the crash is repeatable; playing without vsync will give you a nice framerate boost.

2 Likes

not to worry, and thanks for the followup! :+1:

so, @not_owen_wilson, this still strikes me as a worthy “workaround” options for folks with onboard Intel graphics cards… yes? can we provide a more specific set of criteria for users to check for?

just bumping my issue, as it hasnt been resolved and I still cant play T.T