I can't get past the prepare to embark screen something about GL_FRAMEBUFFER error

Here is a screenshot

I just recently had an openGL error. if you have a Nividia graphics card a new driver up date just came out.

Also if you could upload your stonehearth.log file located in your StoneHearth folder, it may allow the devs to see what process is throwing the error.

In addition, are you using any mods.

I don’t think i have any mods right now here is the stonehearth.log though
2016-05-25 00:17:57.639006 | server | 1 | app | Stonehearth Version 0.15.0.2924 (x64)
2016-05-25 00:17:57.639006 | server | 1 | core.config | user id is 89d6d984-21c4-11e6-bf5e-dc0ea1cf28d8
2016-05-25 00:17:57.639006 | server | 1 | core.config | session id is 13d829ae-21cb-11e6-ac4f-dc0ea1cf28d8
2016-05-25 00:17:57.639006 | server | 0 | core.system | Initializing crash reporter
2016-05-25 00:17:58.170808 | server | 0 | lua.data | lua jit is disabled
2016-05-25 00:17:58.170808 | server | 1 | resources | Module candledark version 1 is out of data (expected: 2)
2016-05-25 00:17:58.170808 | server | 1 | resources | Could not find hash for module “cookmod”.
2016-05-25 00:17:58.186408 | server | 1 | resources | Module frostfeast version 1 is out of data (expected: 2)
2016-05-25 00:17:58.186408 | server | 1 | resources | Module rayyas_children_ui version 2 is deferred load)
2016-05-25 00:17:58.280008 | server | 1 | resources | Modules have been modified by the user!
2016-05-25 00:17:58.347211 | server | 1 | app | Running Stonehearth server on port 44981
2016-05-25 00:17:58.347211 | server | 0 | physics.navgrid | subspace pathfinder is enabled
2016-05-25 00:17:58.349211 | client | 1 | renderer.renderer | Initializing OpenGL
2016-05-25 00:17:58.353211 | client | 1 | renderer.renderer | Determining window placement
2016-05-25 00:17:58.353211 | client | 1 | renderer.renderer | Selecting monitor at 8, 52
2016-05-25 00:17:58.353211 | client | 1 | renderer.renderer | Creating OpenGL Window
2016-05-25 00:17:58.371811 | server | 1 | mod radiant | lua controller lifetime tracking set to "nil"
2016-05-25 00:17:58.403011 | client | 1 | renderer.renderer | Creating OpenGL Context
2016-05-25 00:17:58.403011 | client | 1 | renderer.renderer | Finished OpenGL Initialization
2016-05-25 00:17:58.403011 | client | 1 | horde.general | Initializing GL2 backend using OpenGL driver ‘3.0.0 - Build 8.15.10.2342’ by ‘Intel’ on 'Intel® HD Graphics Family’
2016-05-25 00:17:58.403011 | server | 0 | mod stonehearth.ai.service | [] enable_cpp_compound_action is on
2016-05-25 00:17:58.403011 | client | 2 | horde.general | Renderer: No multisampling for render targets available
2016-05-25 00:17:59.329426 | client | 1 | browser | cef started.
2016-05-25 00:17:59.329426 | client | 2 | browser | Navigate called without an existing browser!
2016-05-25 00:17:59.329426 | thread7056 | 2 | browser | Doing a buffered navigation…
2016-05-25 00:17:59.549827 | server | 1 | lua.memory | lua shared heap size: 11.570 MB.
2016-05-25 00:17:59.549827 | server | 1 | lua.memory | o: outstanding allocs
2016-05-25 00:17:59.549827 | server | 1 | lua.memory | 64 bytes (o: 30227) : ########################################
2016-05-25 00:17:59.549827 | server | 1 | lua.memory | 40 bytes (o: 14355) : ##################
2016-05-25 00:17:59.549827 | server | 1 | lua.memory | 160 bytes (o: 5898) : #######
2016-05-25 00:17:59.549827 | server | 1 | lua.memory | 80 bytes (o: 5438) : #######
2016-05-25 00:17:59.549827 | server | 1 | lua.memory | 48 bytes (o: 5388) : #######
2016-05-25 00:17:59.549827 | server | 1 | lua.memory | … remaining allocs are each < 5% of the count
2016-05-25 00:17:59.565427 | server | 2 | network | server allocating new send buffer (total: 0)
2016-05-25 00:17:59.581027 | client | 0 | physics.navgrid | subspace pathfinder is enabled
2016-05-25 00:17:59.596627 | client | 1 | mod radiant | lua controller lifetime tracking set to "nil"
2016-05-25 00:17:59.596627 | client | 2 | network | client allocating new send buffer (total: 0)
2016-05-25 00:17:59.646427 | client | 1 | client.core | user feedback is on
2016-05-25 00:17:59.677627 | server | 2 | network | server allocating new send buffer (total: 0)
2016-05-25 00:17:59.728229 | server | 2 | network | server allocating new send buffer (total: 0)
2016-05-25 00:17:59.778232 | server | 2 | network | server allocating new send buffer (total: 0)
2016-05-25 00:17:59.829235 | server | 2 | network | server allocating new send buffer (total: 0)
2016-05-25 00:17:59.880238 | server | 2 | network | server allocating new send buffer (total: 0)
2016-05-25 00:17:59.930241 | server | 2 | network | server allocating new send buffer (total: 0)
2016-05-25 00:17:59.981243 | server | 2 | network | server allocating new send buffer (total: 0)
2016-05-25 00:18:00.031246 | server | 2 | network | server allocating new send buffer (total: 0)
2016-05-25 00:18:00.124252 | server | 1 | simulation.remote_client | started buffering client updates. (seq:10 ack:0)
2016-05-25 00:18:00.503266 | server | 1 | simulation.remote_client | stopped buffering client updates. (seq:10 ack:10)
2016-05-25 00:18:01.182281 | server | 2 | simulation.core | game loop exhausted before any jobs processed!
2016-05-25 00:18:08.761613 | client | 1 | client.core | save game directory does not exist!
2016-05-25 00:18:30.955524 | server | 0 | mod stonehearth | ai slow start is enabled
2016-05-25 00:18:30.956524 | server | 0 | mod ai | cpp ai is enabled.
2016-05-25 00:18:31.407549 | server | 0 | ai.execution_frame | (2797 Тихон Твердоруков(а)) [stonehearth:top] ai slow start is 0
2016-05-25 00:18:31.432551 | server | 0 | simulation.core | took 133 ms to update game state
2016-05-25 00:18:31.432551 | server | 2 | simulation.core | game loop exhausted before any jobs processed!
2016-05-25 00:18:31.575554 | client | 1 | rpc | critical error in http reactor: could not trace[trace 283 7]
2016-05-25 00:18:32.328580 | client | 2 | horde.general | Attempting risky mipmap generation (64, 64, 1909, 1401)
2016-05-25 00:18:32.701583 | server | 1 | simulation.remote_client | started buffering client updates. (seq:623 ack:613)
2016-05-25 00:18:34.195589 | client | 1 | horde.general | raw shader compile error: ERROR: 0:110: ‘const 3-component vector of float’ : cannot declare arrays of this qualifier
ERROR: 0:110: ‘const’ : non-matching types (using implicit conversion) for const initializer
ERROR: 0:132: ‘assign’ : cannot convert from ‘float’ to ‘varying 3-component vector of float’

2016-05-25 00:18:34.195589 | client | 1 | horde.general | Shader resource ‘shaders/voxel/debug_color.shader’: Failed to compile shader.
2016-05-25 00:18:34.205589 | client | 1 | horde.general | Bind Frambuffer error: 2, 0, 8cdb, 0
2016-05-25 00:18:34.205589 | client | 0 | app | Assertion Failed: status == GL_FRAMEBUFFER_COMPLETE_EXT(C:\rb\ihome\root\SH-OB-BUILD\stonehearth\source\horde3d\Source\Horde3DEngine\egRendererBase.cpp:1266)
2016-05-25 00:18:59.600835 | server | 1 | lua.memory | lua shared heap size: 14.169 MB.
2016-05-25 00:18:59.600835 | server | 1 | lua.memory | o: outstanding allocs
2016-05-25 00:18:59.600835 | server | 1 | lua.memory | 64 bytes (o: 39124) : ########################################
2016-05-25 00:18:59.600835 | server | 1 | lua.memory | 40 bytes (o: 36469) : #####################################
2016-05-25 00:18:59.600835 | server | 1 | lua.memory | 96 bytes (o: 16012) : ################
2016-05-25 00:18:59.600835 | server | 1 | lua.memory | 48 bytes (o: 10054) : ##########
2016-05-25 00:18:59.600835 | server | 1 | lua.memory | 72 bytes (o: 7385) : #######
2016-05-25 00:18:59.600835 | server | 1 | lua.memory | … remaining allocs are each < 5% of the count
2016-05-25 00:19:08.396884 | client | 0 | sysinfo | Memory Stats: Fatal Exception
2016-05-25 00:19:08.396884 | client | 0 | sysinfo | Total System Memory: 3.945 GB (4236099584 bytes)
2016-05-25 00:19:08.396884 | client | 0 | sysinfo | Current Memory Usage: 522.750 MB (548143104 bytes)
2016-05-25 00:19:08.396884 | client | 0 | sysinfo | Total Address Space: 8.000 TB (8796092891136 bytes)
2016-05-25 00:19:08.396884 | client | 0 | sysinfo | Available Address Space: 7.999 TB (8794611077120 bytes)
2016-05-25 00:19:08.396884 | client | 0 | sysinfo | Used Address Space: 1.380 GB (1481814016 bytes)

Also about the drivers i think my laptop’s graphics card is currently intel hd graphics family or something of the sort my laptop’s graphics card got burnt out a while back

Ok I think this is all of the portion that relates to the error.

I believe this is showing that your are using an Intel based graphic chip. Checking to see if there is a newer driver version could help. edit: just saw where you posted about the Intel chipset)

@8BitCrab Have you seen this type of error before?

This is the link to Intel graphic drivers. Just incase you wanted to check.

edit: It looks like they had a new driver release on the 13th of this month (11 days ago)

probably, but if i have i’ve forgotten it :sweat_smile: i’m going to page @Albert for this.

1 Like

Update drivers “Intel® HD Graphics Family” or Update Windows 7 to Service Pack 1

(Please upgrade your Windows first with Windows Update or try to download manually Service Pack 1)

1 Like

Ok tnx I’ll try updating my driver tomorrow after class, also what do u mean to update windows 7 to service pack 1?

You can’t play the game if you don’t have installed Windows 7 with Service Pack 1 :wink:

http://windows.microsoft.com/en-us/windows7/install-windows-7-service-pack-1

@LaGrosseChoco I’ll check up on that as soon as i get home tomorrow tnx!

I think they are concluding from your screenshot that you are using windows 7. You OS must be windows 7 service pack 1 or later for the game to function correctly,

So which should i prioritize on doing first the windows pack 1 or the driver update?

Try the windows pack 1 first, it seems like that is the bigger issue here,

1 Like

OK, so I installed the windows service pack 1, and sadly it didn’t work, currently checking again if maybe the service pack wasn’t all installed in one go, but so far no luck. Also for the driver update how do i know which driver i should download? i downloaded the Intel Driver Update Utility 2.5 thing and when I ask it to scan it doesn’t have any drivers that I can update to.

Also hurray for bad internet service for making these things extra difficult for me

Please remove candledark and cookmod and try again… Candledark wasnt updated for months xD

Also the is lots of buffer so it looks like it cant get the data from the Servers… Perhaps you have a Firewall Kaspersky Avira etc?

@wiese2007 I don’t think thats the problem my friend has the same mods as well and his game works just fine. Actually we even have the same model laptop drom lenovo and he can play the game, difference between our computers would bebthat he has windows 10 while i have windows 7

1 Like

Ok then, I updated my laptop os to Windows 10 and the game can get past the embark screen now! Thanks for everyone who helped me out!

3 Likes