Stonehearth using Integrated GPU over Discrete GPU

Hey guys.

I have an Intel i7-4702HQ (which has an embedded 4600HD).
I also have a Nvidia GT 750M.

Stonehearth selects the 4600HD to use as it’s primary adapter (it probably enumerates first).
Since my discrete GPU is so much stronger, it’d be great to be able to override this selection.
Is there a way to force apdapter 1 instead of adapter 0? I’m perfectly comfortable using the console until this gets a GUI option.


good question… @not_owen_wilson, lend us your expertise! :smile:

I am not sure if you can do it in game yet. I haven’t found a way. But to be honest, I haven’t looked that hard -.-

For my laptop I added a stonehearth rule for 3d applications. The process is very simple…

Manage 3D settings within the NVidia console. On the Program Settings tab ‘Add’ Stonehearth.exe and then select your 750 from the dropdown list.


I had this same problem, and I did what Froggy said above, but now my game crashes every 5 minutes with no error message and I think this may have something to do with it

Mine is rock solid, and a great deal faster. You should probably submit a bug report

I didn’t know the control panel was still a thing! I thought Geforce experience replaced it. Thanks.

Also I can confirm, my Stonehearth is stable with this and way faster.

1 Like