Stonehearth Save Corruption? [Latest Build]

I have no idea how this bug took place and there is no other way to prove this bug exists other than to just trust me that I’m telling the truth.

I’ll now begin to describe the bug.

  1. I started a new village, zoned two stockpiles, ordered some hearthlings to gather some resources.

  2. Then I assigned hearthlings some jobs (carpenter and trapper)

  3. I saved the game.

  4. I tried building a 2-story building. I encountered a bug where the hearthlings just weren’t building the second story so I re-load the previous save.

  5. I notice, in my saved game, that although I had saved with a carpenter and trapper job occupied, there was only a trapper.

So I tried reassigning the the same hearthling to become a carpenter. Well, no use. There was not carpenter tool anyways. I tried reassigning another hearthling to become a carpenter. No use.

The bug here is that the carpenter job was not saved during the save or something. And that the carpenter tool completely disappeared during the game. Reassigning the job does not work even if the icon is highlighted as available in the job menu.

Second bug.

Citizens are starving to death on my second story. They aren’t coming down despite fresh food being available. There are hand-made stairs leading to the first floor so the path is there.

I’m excited that you guys released Alpha 11 so quick. But releasing it so quick has had some undesirable consequences. Try to take your time in the future. These here are game-breaking bugs.

Your workers seems to be stuck at the 2nd story, try to build a ladder inside the 2nd story that they could get out.
For the first bug, you’re sure that your carpenter didn’t die ? (starving maybe)

First: I shouldn’t have to build a ladder inside the second story. And I can’t because there are stairs in the way.

The other reason is because I’m not sure if the slice tool allows me to view a building story by story (this used to be a feature) and removing ladders would become a pain.

For the first bug, it was the before the first night. Have you ever heard of a hearthling die of starvation on the first night? I also had food. And a full roster of hearthlings on the save.

So no. The carpenter did not die of starvation.

I’ll try to clarify the first bug:
Loaded save did not save my citizen’s carpenter job status.
Carpenter job on job menu still enabled (meaning that apparently I can approve a citizen to become a carpenter).
Changing a job to carpenter has no effect because the tool is not there in the save. And the carpenter does not have job as a carpenter.

1 Like

I was thinking a ladder like the first on my screenshot. And if they don’t get out of the wall after puting the ladder 1 make the ladder 2. Then destroy the ladder just after they got out.
;

Also I can’t see in your screen but, either your stair is not finished and your hearthlings could then access to the 2nd story and remove the ladders after your building is finished eitheir your stairs don’t work properly surely because of the design you made. As said above you could simply remove them after they got out after the 2nd story.

Yes slice tool would allow to view your building story by story, level by level.
But if you use the floor tools to make the floor of the 2nd story (it seems to) you could then view every story of your building by using the “House” button next to the slice one/slice tool.

Do you check the inventory (tower icon) to be sure the handsaw is missing ?
If it’s really missing, can’t help you on that :confused:

Hey, I’m not a beginner at this nor am I new to Stonehearth.

Check my previous posts where I had done similar roundabouts to complete multi-story buildings. I’m not unfamiliar with the concept of adding ladders.

The fact is, that the pathing for building is not in a good state and continuously using roundabout methods to get things done is not going to help the game.

I was unaware of the new house-slice view feature (is that for real? The devs listened to us! Yay!)

And yes. The handsaw really is missing from the stockpile and yet the button for carpenter is still enabled. Hence the ‘Active Bug’ label.

Last but not least, I don’t really mind. I just turn on Stonehearth once in a while and see what bugs I get.

You’re a college student, I’m a college student. Let us both assume we have the intellectual capacity to verify if a bug actually exists alright? I’m not looking for a workaround. I’m posting this for the devs so that they can fix it in the future for the next build.

1 Like

Man, that feature has been there from the first time they revamped the UI at least (maybe even from before), you sure didn’t notice?? :frowning:

And thanks for reporting. It’s really weird that the carpenter wasn’t saved. But definitely a bug since you say that you can’t promote anyone again.

1 Like