Stonehearth on Steam issues


I hosted a game with a friend at my house and we could play together without any issue. However when he went back to his place, the game would not let him connect to me anymore (although we played through steam).

I can however connect to him. I have done all port forwarding and enabled all ports as per Steam’s guide.

Steps to reproduce:

  1. I host a game.
  2. He cannot connect.

Expected Results:

He should connect without an issue.

Actual Results:

He gets to “Loading Duck” and cannot pass it.



Version Number and Mods in use:

No mods, stable version on steam.

System Information:

Intel i7-8750H CPU @ 2.20GHz 2.21 Ghz
Ram: 16 GB
OS: Windows 10 x64
Video: GeForce GTX 1050 Ti

Your friend may have some network configuration that doesn’t allow connecting to other networks.

It may take a while to connect, does he crash after a while of waiting in the spinning poyo?

Could you upload his stonehearth.log from after waiting in that connecting status?
It’s a text file inside C:\Program Files (x86)\Steam\steamapps\common\Stonehearth.

Unfortunately I am a new user and cannot upload files, here is a pastebin from MY side. Will upload his as well when he sends it to me and if you need it:

1 Like

Thanks. I’ve bumped your user level so you should be able to upload files now.

Thanks for the quick reply as well! He would not get any error and he waited for about 5-10 minutes once. On my side it would say he is “Connecting”.

When I try to join him, it would instantly connect.

stonehearth.log (10.7 KB)

Here is his stonehearth.log as well.

1 Like

stonehearth (1).log (11.4 KB)
stonehearth-host(1).log (19.9 KB)
stonehearth (2).log (10.7 KB)
stonehearth-host(2).log (41.9 KB)

We did some more testing:

(1) Tried to continue a save we had. He was at my house (same internet) and could connect without issue.
(2) Tried to make a new game. Still waiting (logs say he disconnects at :18 minutes and he closes window at :24.

It sounds like his internet connection may have better upload speeds, which would allow you to connect to his game without timing out. Could you test the upload speeds?

How would you like me to test that so the results are meaningful to you?

Could it be something related to MTU settings on my router?

We tried with below are the results

My speed

His speed

stonehearth -no-firewall-him (16.8 KB)
stonehearth-no-firewall-me.log (34.3 KB)

So these logs include:

  1. We both disable firewall.
  2. I host a game, he tries to connect. He gets rotating chicken.
  3. He hosts a game, I try to connect. I connect in about 2-3 seconds.

Any suggestions? :smiley:

honestly my only thought is “is his pc faster? because the log seems resource starved” and you are running a 2.21 Ghz processor. which is… not that great for SH’s hungry behaviour. normally more cores help, but in the case of SH you are better off with old fashioned fast chunky fat cores, in lesser amount)

for refference, im runnign a 2500k that doesnt mind running one core at nearly 5Ghz…

I’m going to second @Wouter_Sikkema’s, based on my own experience;

In a group of five, we compared internet speeds; I ranked second out of us five. However, my computer is a potent little machine, and where the first host was noticing lag spikes when people used the Builder resulting in being inclined to pause the game, I never noted any serious lag when I was hosting even when more than one person was using the Builder at the same time.

1 Like

Does he use the same computer in your home and in his home? :thinking:

If he can’t connect from his home it sounds like a problem on the network. Does your computer accept connections from computers that aren’t on the same local network?
Does this happen with other games? (In the past, it was an issue related to Steam privacy settings, and affected many games).

Not sure what else to suggest :confused:

Yes he used the same PC.

My processor is 8th Gen 6-core, no clue why would that be the issue here, especially since his is way slower and older. My PC in this case is the better one, so that theory should either be somehow reversed or we should completely drop that one off. For future ref., its Asus RoG Strix GL503.

Steam privacy settings, can you extend this? Might be something to that, since we had also some issues when doing 3+ games in Civilization 6. We could play together but as soon as a 3rd person joined the fray, it would go mayhem. Desyncs either me or the 3rd person, stuff like that.

However, my friend could play with 2 other people, without a fault.

My guess is a network-related issue based on some filtering or blocking of packages/connections. Problem is - I don’t know what to look for. When I host a stonehearth game, which port should he be able to connect to and how does that wire up with Steam?

I can’t remember if it was when Steam changed their Friend list UI, it affected many games.
Sometimes when a player’s profile was private, nobody could join them (I think? or maybe it was the opposite).

But in your case you were able to connect while in the same local network, so maybe it’s not that.

I’m not sure how does the game choose the port (that’s probably handled by the Steam API). Perhaps you can try forcing to use that port you forwarded like for non-Steam users (not sure if it would work or if the Steam API would overwrite it).

These go in the user_settings.json at the same level than user_id. Later if the client restarts the game to play singleplayer, the game will attempt to connect to the host so it might take a bit until it fails to connect and brings him to the main menu, so he might want to remove these settings.

We will try that. If this works though, then that would be some sort of a steam issue.

Will update once I have more info! :slight_smile:

1 Like