[Res] Upgraded computer, Fresh OS install, unable to play game

So previously I was able to play Stonehearth just fine. Yesterday I purchased some new computer parts to perform an upgrade. One of those items was an SSD so I thought, might as well start completely fresh! Unfortunately, this seems to have broken stonehearth. Previously I was running an AMD Phenom II X6 1090T on an AMD 890 Chipset, the new rig is an i7-4790K on a Z97 chipset. Both use the same GTX 780 GPU. I have tried both the Humble Bundle and Steam version, both with the 64 bit and 32 bit clients. I have tried installing it and running it off of both drives. Nada. Stonehearth crashes before even opening. I’ve dug through event viewer and here’s what I am getting:

Faulting application name: Stonehearth.exe, version:, time stamp: 0x551091e2
Faulting module name: libcef.dll, version: 3.2171.1902.0, time stamp: 0x5452e9a4
Exception code: 0xc000001d
Fault offset: 0x0000000001c7b323
Faulting process id: 0x1650
Faulting application start time: 0x01d0860a9a8993b1
Faulting application path: D:\Program Files (x86)\Steam\steamapps\common\Stonehearth\x64\Stonehearth.exe
Faulting module path: D:\Program Files (x86)\Steam\steamapps\common\Stonehearth\x64\libcef.dll

Windows cannot access the file for one of the following reasons: there is a problem with the network connection, the disk that the file is stored on, or the storage drivers installed on this computer; or the disk is missing. Windows closed the program Stonehearth because of this error.

Program: Stonehearth

The error value is listed in the Additional Data section.
User Action

  1. Open the file again. This situation might be a temporary problem that corrects itself when the program runs again.
  2. If the file still cannot be accessed and
    • It is on the network, your network administrator should verify that there is not a problem with the network and that the server can be contacted.
    • It is on a removable disk, for example, a floppy disk or CD-ROM, verify that the disk is fully inserted into the computer.
  3. Check and repair the file system by running CHKDSK. To run CHKDSK, click Start, click Run, type CMD, and then click OK. At the command prompt, type CHKDSK /F, and then press ENTER.
  4. If the problem persists, restore the file from a backup copy.
  5. Determine whether other files on the same disk can be opened. If not, the disk might be damaged. If it is a hard disk, contact your administrator or computer hardware vendor for further assistance.

Additional Data
Error value: 00000000

when I run it, the game gets far enough to create the User_settings.json. The log isn’t showing much…

2015-May-03 21:57:52.965529 | server | 1 | app | Stonehearth Version (x64)
2015-May-03 21:57:52.965529 | server | 1 | core.config | user id is cc2bcc3a-f200-11e4-8874-d8cb8a3bf84f
2015-May-03 21:57:52.965529 | server | 1 | core.config | session id is f99c3ceb-f200-11e4-adc9-d8cb8a3bf84f
2015-May-03 21:57:52.965529 | server | 1 | core.timer | QPC count: 11250404692, frequency: 3906308
2015-May-03 21:57:52.965529 | server | 1 | core.timer | QPC count: 11250404815, frequency: 3906308
2015-May-03 21:57:52.965529 | server | 1 | core.timer | QPC count: 11250404902, frequency: 3906308
2015-May-03 21:57:52.965529 | server | 1 | core.timer | QPC count: 11250405012, frequency: 3906308
2015-May-03 21:57:52.965529 | server | 1 | core.timer | QPC count: 11250405096, frequency: 3906308
2015-May-03 21:57:52.965529 | server | 1 | core.timer | QPC count: 11250405208, frequency: 3906308
2015-May-03 21:57:52.965529 | server | 1 | core.timer | QPC count: 11250405292, frequency: 3906308
2015-May-03 21:57:52.965529 | server | 1 | core.timer | QPC count: 11250405358, frequency: 3906308
2015-May-03 21:57:52.965529 | server | 0 | core.system | Initializing crash reporter
2015-May-03 21:57:53.466558 | server | 0 | lua.code | lua jit disabled in 64-bit builds. set force_lua_jit to override
2015-May-03 21:57:53.466558 | server | 0 | lua.data | lua jit is disabled
2015-May-03 21:57:53.898582 | server | 1 | resources | Modules are verified pristine.
2015-May-03 21:57:53.906583 | server | 1 | app | Running Stonehearth server on port 33579

Am I perhaps missing some critical infrastructure the game needs? Anyone have a fix? I looked through the threads where people had issues but I didn’t see anything like my problem.

I am a bit sad, I really wanted to see water this weekend ; ;

I’m running this:

AMD Phenom II X4 965 Processor, ~3.4GHz
16 GB PC3-12800
AMD Radeon HD 7770 (x2)
Crucial 256GB M4 SSD

with no problems. That being said, I see your issue right here;

Couple things. The first I would try would be checking the folder’s permissions. A recent update in WIndows 8.1 for some stupid reason has locked down any drives it deems to have OS files on. This would include Program Files. So try going to …\Program Files (x86)\Steam\steamapps\common, right click on Stonehearth, click the security tab, and basically give full control to all everyone listed. I know someone out there will argue the safety of this, but it worked for me with other programs like Minecraft.

If this doesn’t work, then you’ve got a driver issue with said drive, and we’ll have to take it from there.


I ran as administrator originally in case it was a permissions issue. I changed the permissions anyway, just in case and it’s definitely not that, still crashing at the same point. Drive is fine, every other game and program installed on it is working just fine.

1 Like

Because that’s calling it a bad harddrive. What about drivers? Are the correct drivers for the drive installed?

This is another reason I think it’s permissions.

My only other question, have you tried doing an integrity check with Steam?

1 Like

Faulting module path: D:\Program Files (x86)\Steam\steamapps\common\Stonehearth\x64\libcef.dll

I’ve seen this problem multiple times around the forum and it’s happened to me a few times too. Usually a full install/uninstall will do it (and by this I mean nuke all SH files you have anywhere in your computer.) Do you have libcef.dll in the location that it’s looking for it?


I’ve tried a full nuke on files, and done integrity checks. I haven’t moved any stonehearth files from where they default to. Does give me an idea to try some things. Thanks for all the help, I really miss playing it.

Alright! So when I did a full nuke I missed something rather key: On my C drive (the SSD) I had apparently left the user_settings.json and the log file (and ONLY those two files) in the steam directory. Nuking those two fixed the steam installation on the D drive. I do not know why. It’s weirding me the heck out, but it’s fixed!