Crash on startup

When I hit play button on steam or start the stonehearth.exe file it just says.

Failed to open file for writing: input/output error Stonehearth/stonehearth.log

Not exactly sure what i should do here. I thought it might just be a file out of place so i verified the game cache and have re downloaded it a few times. I have updated my drivers and looking around for an issue and i have not come across any.
Any help would be appreciated!

hey there @sichip, welcome to the discourse :smile:

have you taken a look through this thread yet?
http://discourse.stonehearth.net/t/crashing-on-start-read-this-updated-november-29/13297?u=8bitcrab

I have @8BitCrab

Neither of them are my problem
As i explain i have updated my drivers. I also don’t have lavasoft ad-aware

heyho @sichip can you provide us your dxdiag.log and stonehearth.log? so that we can see your pc specs and the errormessage? would be helpfull :smiley:

just click start and there run, then insert dxdiag. then click save
all informations after loading and save the txt file somewhere where you
can find it and then upload it here.

Thx!

Not exactly sure where the “dxdiag.log” is or where the “stonehearth.log” is located in the stonehearth folder. Maybe im just not seeing them. I have looked at a few of the stonehearth text files. But they dont have any recent reports on them. all from March when i last played the game.

But when i look at the problem in general it looks liked its missing the stonehearth.log file because it says in the error message “failed to open Stonehearth/stonehearth.log”

There is no recent Crash log on this topic. The last crash log was at the end of May which was when i last played the game. There is no log since then.

the stonehearth.log will be created when you open a game … if its give you an error that it cant open it / create it … i think you have an problem with your rights - can you try to start stonehearth with adminrights

Yes, it sounds like it. @sichip, do you have permissions (read / write) on the folder where Stonehearth is installed?

Also, welcome to the forum :slight_smile:

1 Like

Wiese2007 and Relyss have it correct. The game is trying to create a file stonehearth.log where it is installed, but Windows is rejecting the operation. Try launching as adminstrator or installing into a different folder where you have write permissions.

3 Likes

It give me the same error message. As it would when i normally run it.

It might have something to do with switching hard drives. Which when i moved things over i copied them instead of just moving them. Thats my fault. But that was last year and i have played the game multiple times since then.

that shouldnt be a problem because its drm free - so you can copy them and send it to another folder and it will still works xD only steam would have a problem with this - because the links will be unusable.

sichip for start as admin becarefull - there are two stonehearth.exe ^^ you must enable for both of them under compatibility the admin rights (one in the main folder and one in the folder x64)

Ok thats what i thought about the Hard Drive Switch. I do also know about the Two Stonehearth.exe files. Neither of them worked.

As well as this is my own built computer so i have admin rights. I also right clicked and said “run as Admin” it still gives me the same error message.

What happens if you copy the entire stonehearth folder to a non-steam, non-windows folder and launch from there?

1 Like

Actually, also check permissions on the stonehearth folder. I remember when switching hard drives that I had some permissions issues afterwards.

2 Likes

Remind me again how to check permissions on a folder? I found the “security” tab in properties but the entire thing confuses me. Im not exactly sure how to use it

If you click on advanced in the bottom right corner it should look a little like this.

If you transferred the hard disk from a previous computer, the inherited drive permissions for folders and subfolders will be for the previous computer, even it had the same name (inherited from D:)

Adding your computers administrators and user groups should resolve your issue. (or will make your computer blow up, which I take no responsibility for!) You may need to take ownership of the drive in order to do this.

You might find this article useful for a step by step https://support.microsoft.com/en-us/kb/2623670

4 Likes

no change. it still gives me the error message