Stonehearth having an error when clicked play


#1

when i opened up stonehearth for the first time today, a popup appeard instead of the game saying:

Error starting application:

boost::filesystem::weakly_canonical: access is denied

pressing ok takes the popup out of the screen and back to steam, not the game
i bought the game very recently (as of july/2018) and im quite exited to play the game. so pls help.


#2

and, yeah i have the latest game btw


#3

Do you have permissions over the folders where the game is installed?
The game will need to create some files in there, like the user_settings.json, or when you save a game, so it needs to be able to create / modify / delete files in the directory where it is installed. (I think it might be some issue like that, since the message says “access is denied”).

Does running it as administrator help? You can try to do so by right clicking Stonehearth in your Steam library, click on Properties, click on the Local Files tab, and then in the Browse Local Files button.
You’ll find the Stonehearth.exe there, right click on it and click on Run as Administrator.


#4

thanks, it did help! but then i tried playing with a friend and i couldnt play, when i was the host, my steam name was missing and there was no invite button, and when my friend was the host and i tried joining, a second stonehearth app would start, giving me the popup of before. :confused:


#5

Yes, Stonehearth must be closed before trying to join a multiplayer game. When you click Join Game on the Steam Friends list, it will automatically open and show the connection screen, which lists any mods from the host, and allows you to continue if both players have the same version and mods.

What do you mean your Steam name was missing and there was no Invite button? We had some issues about this in the past, but it was a bug with private profiles in Steam, and they fixed it eventually.

If you had Steam running, and already started a multiplayer game and placed your banner, then you can go to your Steam Friends list and right click on your friend’s name and click on Invite to Game (or your friend can right click your name in his friends list and click on Join Game). Always after the host has gone through embarkation and placed the banner.


#6

Hopefully im not wasting your time, but when we tried again, my friend already tried placing his banner, and still it didnt work and when i tried being the host with the banner placed, still there was no invite button. Another thing we tried was that my friend tried joining via steam instead of invites, and he found out that while i played stonehearth, i was offline in steam, making me believe that running it on admin. is affecting it somehow.

And sorry again.