Error on launch

Every time I try to launch the game (Steam ver) I get this error

I have uninstalled and reinstalled 4 times to try and fix no luck. I posted on steam for help still no good. Has anyone had this issue?
Steps to reproduce:

Expected Results:

Actual Results:



Version Number and Mods in use:
Up to date as far as this post
System Information:

not sure but from what i see some files are missing

It seems that you don’t have permissions on the folder, @PowerJuiced11.

Are you running the game as administrator?

The game is trying to generate the log file (which happens every time you open the game) but seems that it can’t write it.

Not sure how do i check.
Thank you for the fast response.

On your Steam library, right-click on Stonehearth. Select ‘Properties’, select the ‘Local Files’ tab and click on ‘Browse Local Files’.

This will open the folder where the game is installed. Right-click inside the folder, and click on Properties. Click on the Security tab. You should see your user listed there. Click on it, and check if it has read/write permissions on the section below.

1 Like

Ok I checked that and its good but still same issue.

If you run the game from the folder, instead of from Steam, do you still get the same error?
You can try right-clicking the executable and clicking “Run as administrator”.

Still get same error

Is there an existing stonehearth.log file in that folder that is read-only?

If not, try creating a text file there called stonehearth.log and see what it says.

1 Like

Do you have a stonehearth.log inside the folder? If so, try deleting it and running the game again.

If not, and you have all the permissions to the folder, I’m not sure what could be causing it.
Maybe Steam or some other process is holding the file. Right-click on the task-bar, open the Task Manager, and make sure there are no Stonehearth processes running in the background.

Did you try restarting Steam too? And verifying the integrity of the game cache within Steam?

1 Like

That worked i had the file but it was missing (.log) part so i added and it
worked. Thanks for the help