Stonehearth has stopped working on windows 10

I tried to use compatibility mode and verify integrity game cache but it didn’t work.
my pc system

@Patawee_Srikasumbun Have you tried running the game directly from the folder?

I try to.didn’t work

any chance this is a dual screen setup ?

Hey there @Patawee_Srikasumbun, welcome to the Discourse :smiley:!

Sorry to hear you are having trouble playing Stonehearth. Let’s see if we can help you get it working.

  1. Did the game work previously, or is this your first attempt at playing?
  2. If it worked previously, when did it stop working?
  3. Have you attempted all the steps here? Our crashing on start guide covers many common issues.
  4. When you say “stopped working” can you be more specific, please? Does the game fail to launch at all? Does it give an error then crash, randomly crash while playing, display only a white screen, etc.
  5. Can you upload your stonehearth.log and crash.dmp files for us to review? They’ll be located in your game directory, which by default is C:\Program Files (x86)\Steam\steamapps\common\Stonehearth. Note that depending on the type of crash, there may not be a crash.dmp file.

stonehearth.log (2.9 KB)


Try going into your x64 folder there and launching the 64bit Stonehearth version

Thanks for the log and screenshots. I’m not seeing anything in the log that’s would indicate what is happening (other than it is crashing), and I see that there is no crash.dmp being created. Can you please answer questions 1 & 2 from above, so we can try and narrow down the problem?

1 Like

Is there a reason you’re enabling compatibility mode? I dont use to feature for any steam games and I’m on windows 10

What do you have in your user_settings.json file, @Patawee_Srikasumbun?
(It should be inside the same folder than the stonehearth.log, it’s just a text file).

Looks like the game is hanging instead of crashing, which would point to a firewall or security software issue. You might try running these three commands to reset the built in firewall, the TCP/IP interface, and Windows Sockets:

netsh advfirewall reset

netsh int ip reset c:\resetlog.txt

netsh winsock reset

Otherwise you could dump the list of processes from task manager and we can check it for any security or anti-malware problems that might be the issue.