Game crashing on launch - previously worked

Hi having same issues. I was able to play the game with no problem using Windows 10. Due to being away I’ve not played this.

However, now it justs opens a window and then closes. I’m currently playing regular feed. Used to use the beta feed. Neither work.

I’ve tried Win 8 & 7 compatability mode. I have a crash report but dont know how to access / attach to post.

Hey there @Vaughan_Truelove, sorry to hear that you are having trouble launching the game.

I have upgraded your account to basic user, so you should now be able to upload your crash report directly to the Discourse. Just reply to this thread and drag and drop the file into your post. It should upload automatically.

Thanks Jomaxro,

Much apreciating the offer of assistance here - very frustrating :weary:

Hmm, I get an error saying the file needs to be in a specific format. The crash file has ‘*.dmp’ ending and is not one of the ones listed (I think it is expecting some form of txt, etc file to drag & drop. Am I missing something??) :worried:

Only other file of same date is the “Stonehearth log” that is a txt file. Not sure if this is what you need, but is included below.

stonehearth.log (3.9 KB)




Hey there @Vaughan_Truelove, sorry about that, the discourse does restrict file types like that…I will ask if we can get .dmp files allowed. In the meantime, if you “zip” the crash.dmp (right click file --> send to --> compressed (zipped) folder) you should be able to upload that.


Yay. That worked. Why shouldn’t I have thought of that??!!

Enjoy. (20.0 KB)

Hey there @Vaughan_Truelove, I just took a quick look through the crash dump and log. I am by no means an expert, (that would be @Albert), but it seems that there may be a file that has been modified in the game.

Do you currently, or have you previously run any mods? Have you attempted to change any of the files in stonehearth.smod?

If you have mods, I would suggest removing them temporarily to see if that works. If not, I would suggest completely deleting the game folder (from Windows Explorer, Steam doesn’t always do it full), and reinstalling the game. Let me know what happens!

@Vaughan_Truelove - Yes, something is wrong with the files. Can you delete and reinstall?


Thanks man.
First oof the bat, thanks for your speedy replies - very helpful.
Second - hey even if you may feal your not so tech savy on this, don’t mark yourself down. Sometimes a layman viewpoint can be of assistance.

As to mods - I added the ‘item picker’ option for the game (what I’m calling it anyways) the one where you have an extra menu to place items in the world. Mainly to see how the game worked with this and understand higher processes in game (technically - to me anyways - a cheet if used without using it as a learning tool).

So I’ll get rid of that to see if this is causing a problem.

Ahhhh. Last time I just uninstalled - reinstalled from steam. I’ll uninstall and delete the folder. Then reinstall and get back to you (if that’s ok?!?) So you may get a double response :blush:

As to the delete of folder and removing mods- see you know your stuff !! :smile:

Thanks again and hope this has encouraged you to assist others where you can :grin:

Jomaxra & Albert,

I am now a happy bunny :gift::smile:

The Stonehearth music is now happily playing as I type and is ready to play. Shows that I’m on Alpha 12.

So, ready to rock n roll!

Thank you both for looking into this. Any other issues I know where to come.


Vaughan Truelove