Stonehearth Crash of Startup (reset network / firewall)

I haven’t been able to play the game for a while now because every time i’ve tried to launch the game through steam or through the individual exe’s the game crashes immediately.

log file


[Upload your crash.dmp (from the game install directory). If you are a new user and thus unable to upload please say so and we will assist you.]
no crash.dmp file

I’m using the current steam build and i haven’t installed any mods.
Using windows 10 64 bit
nvidia gtx970
intel i-7-4770 3.6ghz
12gig ram

Ive tried all the steps in this post but nothing seems to help.**

Hi @Stefano, welcome to the forum :slight_smile:

Have you tried updating your graphic drivers from here? : NVIDIA DRIVERS GeForce Game Ready Driver WHQL (I think these are the ones for your graphics card).

Which was the last Stonehearth version that you could play? Have you been able to play A18 r663 when it was released?

I updated the drivers a couple weeks ago and it didn’t do anything to help.

I was not able to play r663. The last version i’m sure i was able to play was pre-a18 releases.

Hmm…this is certainly odd. Your graphics drivers are technically out-of-date, but only because NVIDIA released new drivers Thursday. I’m still using the same drivers you are so I doubt that is the issue - though updating never hurts.

I am surprised that there isn’t a crash.dmp file, seeing as the crash reporter is started according to your logs.

Some suggestions (try launching the game after each one):

  1. Update your drivers to the latest version. I personally doubt it will help in this case, but it won’t hurt anything.
  2. Try deleting your user_settings.json file. This will clear your graphics, sound, and gameplay settings. The file should be automatically recreated when launching the game again.
  3. Delete the entire Stonehearth folder from your steam directory. Important: If you have saved games or templates you wish to keep, be sure to backup your saved_games and saved_objects folders respectively.

If after these 3 steps the game is still insta-crashing, please upload your latest log, and the crash.dmp file (if it exists). If it works, please let us know what fixed the issue!

So I updated the drivers and tried step 2 and 3 neither of them helped with the insta-crash.

I couldn’t find the crash.dmp file in any of the folders so i’m assuming none was generated.

log : stonehearth.log (3.5 KB)

Doubt it will do anything but have you updated your intel drivers lately.
it would not be the first time that a intel driver gives trouble for Nvidia/AMD

i would try and remove both drivers completely and reinstall latest versions starting with the intel one.

Another thought - do you use any Antivirus or Firewall programs? Also, do you have any programs that install browser extensions?

So i checked my Intel drivers and they’re all up to date.

I checked my firewall as well and everything looks fine. I also looked around for any programs that install browser extensions and I don’t have any.

Hey again @Stefano, another user had a very similar issue and was able to solve it be resetting the built in firewall, the TCP/IP interface, and Windows Sockets.

Can you run all 3 in an admin command prompt and see if that helps?

netsh advfirewall reset

netsh int ip reset c:\resetlog.txt

netsh winsock reset

1 Like

Great! Running those 3 commands completely fixed the problem.
Thanks @jomaxro, i can finally get back to playing the game.

1 Like

Awesome! @yshan and @Albert, any thoughts on what might have caused this to occur (and why resetting the Windows networking stack fixed it)?

@jomaxro - It appears that the default settings for the firewall had been set to be more aggressive which prevented Stonehearth from connecting. I’m surprised that a dialog didn’t appear to ask the user for permission (or maybe it did and they denied it.)

@brad - We should include these instructions in our startup crash FAQ.


Thanks @Albert! Any way to provide better feedback to the end user as opposed to simply closing the executable? Not sure if this is something clearly detectable or not…

Good suggestion. We should look into that since this is happening quite often.

1 Like

Was having the same issue here, and tried everything listed on the crash on startup thread before finding this thread. After running all 3 command prompt resets I was able to run the game successfully, so it would be nice to see this info updated into the other thread if it is a known issue.

Unlike the OP I do have a crash.dmp file, so here it is in case that is of use (it even managed to survive me reinstalling): crash.dmp (208.4 KB)

1 Like

Glad that you got it working @Liru, I don’t think there would be any harm adding the commands to the crash on startup thread, but I’d like to get confirmation from @Albert that there won’t be any side effects I’m not thinking of. The commands are only touching the network stack, and only reset to defaults…hmm?

@jomaxro I’m not aware of any harmful side effects. Brad was going to add it to the thread, but if he hasn’t already please feel free to do so!

1 Like

Let me double check and take care of it if needed.