My game dont work no more innit


#1

Summary:

the game used to not open at all but now the window opens and the a not responding message appears

Stonehearth.log:

i dont have any file called stonehearth.log

Attachments:

i cant attatch stuff :confused:

Versions and Mods:

[What version of Stonehearth are you playing? Have you installed any mods?]

System Information:

OS: Windows 10
video card: GTX 970
monitor type: external monitor

Have you attempted basic troubleshooting steps here: http://discourse.stonehearth.net/t/crashing-on-start-read-this-updated-october-28/13297:

i have tried basic troubleshooting

Notes:

ive tried it on another computer that runs windows 10 at college and it worked but was laggy (the computers arent very good)


#2

Welcome to the forums, @HexoSlaya369 :slightly_smiling_face:

You should have a text file called stonehearth inside this directory: C:\Program Files (x86)\Steam\steamapps\common\Stonehearth

There should be a text file called stonehearth.json, and another text file called stonehearth.log, which is the one we need to take a look at.
But it is possible that the game failed before being able to generate the stonehearth.log. I’ve given you permissions to upload files to the forum.

Which troubleshooting steps did you already attempt?


#3

i tried reinstalling the game and it didnt help me, but the stonehearth.log file appeared.
stonehearth.log (5.3 KB)

Edit: ive also updated my drivers and dont have lavasoft


#4

Could you paste the contents of your user_settings.json file?


#5

sorry for the late reply:

{
“user_id” : “df5fb3ec-bfb9-11e6-8177-d8cb8a163434”,
“enable_auto_save” : true,
“enable_analytics” : true,
“alpha_welcome” : {
“hide2” : true
},
“mods” : {
“stonehearth” : {
“tutorial” : {
“hide_camera_tutorial” : true,
“hide_intro_tutorial” : true
},
“enable_speed_three” : true,
“default_storage_filter_none” : false,
“auto_loot” : true,
“randomize_attributes” : false,
“show_hearthling_paths” : false,
“building_auto_queue_crafters” : true,
“max_citizens” : 50,
“hide_happiness_intro” : true
},
“debugtools” : {
“enabled” : false
}
},
“renderer” : {
“run_once” : true,
“use_high_quality” : true,
“enable_ssao” : true,
“enable_shadows” : true,
“msaa_samples” : 1,
“shadow_quality” : 4,
“max_lights” : 125,
“max_shadows” : 8,
“enable_vsync” : false,
“enable_fullscreen” : false,
“screen_width” : 1916,
“screen_height” : 1017,
“draw_distance” : 1000,
“last_window_x” : -8,
“last_window_y” : 32,
“last_screen_x” : 8,
“last_screen_y” : 94
},
“audio” : {
“bgm_volume” : 0.6,
“efx_volume” : 1
},
“force_32_bit” : false,
“language” : “en”
}


#6

Do you have a crash.dmp in the C:\Program Files (x86)\Steam\steamapps\common\Stonehearth folder that you can upload?

The log doesn’t show anything weird except that “Memory Stats: Fatal Exception” near the beginning, can’t tell where is it coming from but it seems the game continued after that.

Have you tried changing “force_32_bit” to true in your user_settings, saving them, and then running the game from the folder instead of from Steam?


#7

crash.dmp (86.4 KB)

and i tried to launch it with 32 bit and it worked but the game lagged a lot and was almost unplayable.


#8

If the game doesn’t crash in 32bit then it’s probably caused by a 3rd party application that’s messing with the game. Didn’t see any of the known ones in your crash.dmp, so I’m not sure what’s exactly causing it.
Have you tried adding an exception for the game in your antivirus?