Stonehearth Executable Deletion (Steam Disk Read Error)


#1

Title:
Stonehearth Executable Deletion (Steam Disk Read Error)

Summary:
Stonehearth won’t fully install in Steam or will Install once then a “Disk Read Error” will appear when trying to load in steam or when trying to re-install. What is actually happenings is that my Anti-Virus was quarantining the executable as a Rogue Virus every time i tried to install… it makes sense why my computer seems to get 30 viruses a day… it’s Stonehearth!

Steps to reproduce:

  1. Have Anti-Virus Running
  2. Install Steam-Unstable Stonehearth
  3. Play once, then exit
  4. Exe is deleted!

Expected Results:
Game would run and not see it as a virus.

Workaround
Disable Anti-Virus

Notes:
Even allowing the program through my specific anti virus (Windows Defender and Ad-aware simultaneously) Didn’t work. I have to turn them both off.

Just thought i’d post this here in case anyone else was tearing their hair out trying to figure out why their game stopped working. :smile:


#2

State what anti-virus your using. Because I both have Mcafee and Avast running and it runs and installs the game fine.


#3

I certainly did, my good man.

:smile:


#4

This might be a problem with ad-aware then as I’m running Windows Defender (though might need to look for alternative security as you know how these things change) and have no issues installing the game.


#5

Yeah, it appears to be Adaware for sure. Quarantines it so fast it’ll make your head spin. I’ve tried adding Stonehearth.exe to the ignore list, we’ll see if that works.