Stockpile, Harvest, and Loot zones do not work on buildings/roads


#1

Graphical Glitch

Stockpile’s graphical region is invisible when dragging from structures like pathways.
small graphical error.

Release -453 Alpha 10 x(64)

Screenshot


Loot and harvest group selection not working on buildings
#2

hey there @Freudian, could you perhaps supply a screenshot to better show what you mean?


#3

I had thought about providing a screenshot but its still a little unclear even with one.
Ive added one anyway, its quite hard to see but when you drag a stockpile out its supposed to show a graphical representation
of how big the stockpile will be, here it only shows the dimensions without the graphic.
this happens when you drag it from a structure like a path or building.


#4

i embedded the screenshot for you, i’ll also just go ahead and page @Albert @yshan @sdee so they can take a look at this strange graphical bug…


#5

After some more playing around it seems its with any of the dragboxes, if your trying to loot, destroy or cancel tasks around or in structures the graphic just doesent show up, and how do i go about paging them?
or is that what you just did ^^?


#6

I haven’t been able to reproduce this on our end. Is anyone else seeing this bug?


#7

I wasn’t able to reproduce either. Between this and the Hoe Stockpile Move Error topic, I get to wondering if maybe Freudian has some save corruption or some game file corruption.


#8

I’ve sort of had this issue while doing the Diadem Depot project a few weeks back. I don’t remember how many tools exactly were affected, but some of them seemed to take the ground block beneath the built voxel and use that for the Y-axis setting for the command perimeter. I know the Loot command struggled with this for certain, as every time I tried gathering something on the floors/roads I built, it wouldn’t pick them up.

@Freudian, if you dig a few voxels away next to one of the roads, does the region show up on the exposed dirt?


#9

I aslo know this bug.
When you try to designate a Stockpile area starting on a Road block, instead of doing in on top of the Road block, the game does it below it, As if the Road blocks didn’t exist. The designated area then extends under the surface level and you can’t see it. That is why the picture does not show it. But those numbers you can see in the picture are the ones that appear when designating areas.
Haven’t tried it for some time because I avoid it automaticaly. When I get home I’ll test it again and corfirm.
If you start designating on a Grass, Rock, or Floor block it does not happen. You can extend then the stockpile over the Road and it’ll work normaly.
With the Loot tool there is a different problem. Wherever you try to start to designate the area to be looted, the tool always does it on ground level. Ignoring anything that may be there, including tree roots, Built blocks, etc. You can only apply the loot tool over grass or original Rock blocks. In case of Roads, again, the tool ignores them and goes straight to the block below them.

I hope this explanation helps understand what happens, correct it, and to avoid it while playing.
In general: Avoid designating from Roads. Do it from a neighbouring “normal” block. And if an unfortunate loot drops on an inadequate place “Console and destroy”.

Have Fun, Kyth.

Ps: After finally being able to check it, in my current build, alpha 11, I can designate a stockpile over a Road without problem. The loot tool still fails.


#10

@Atralane your correct!, the Graphical region shows up on the voxels below roads and structures such as floors and walls.
This is probably down to selection tools ignoring player produced voxels as valid placement/selection for various actions?

can confirm :+1:


#11

@Albert, can you and the team spot this from your end? Or was this already noticed by Alpha 12’s initial release? I haven’t had a chance to test the new version out, so I don’t know how much the engine might have changed or if this was fixed.


#12

@atralane - I haven’t had a chance to look at this again. Might get back to it after fixing the crashing bugs in Alpha 12.


#13

I’ve revisited this in the latest Alpha 12 Dev build, it seems that you can now place stockpiles on roads perfectly fine but looting still seems to select the voxels below the road.
@Kythandra
@Atralane


#14

Yeah, the Loot command was the one I originally observed the issue on. I actually didn’t know how many other area-based actions it affected (although looking back, I can say for certain I didn’t have issues with stockpiles on flat floors or roads, since I did that relatively often during the project construction) There might be some other elevation issues with layers next to each other, but I haven’t experienced any yet.


#15

Done some testing on the newest Alpha 14 Develop-2820 and it seems that the loot command still conflicts with roads, the loot square still seems to loot below the road. In specifics I found it happening with the lightest colour of brown stone material.


#16

Summary:
Since I’m an entomologist of sorts (I like describing bugs), here’s another I suppose everyone knows of. Less of a bug, more of a feature not implemented yet. Group selection (like Harvest or Loot command) can’t be used in or on top of buildings, it is applied only to the ground below.
This makes some things unharvestable/unlootable (as some items currently lack “loot” button and can only be picked up with Loot group selection). For example, if you place a stone or log pile inside a building it can’t be harvested back.

Steps to reproduce:

  1. Try to use Loot or Harvest selection rectangle on something that’s on the floor/roof/slab.
  2. Whoops.

Expected Results:
Selection rectangle should be applied to player-built surfaces, layer based on where’s the cursor pointing at the beginning.

Actual Results:
Selection can only handle ground. When trying to select something above ground level it ignores player-placed blocks (and things ontop of them).

Version Number and Mods in use:
Alpha 15 release 549


#17

Good catch! I feel like I’ve seen this one before though…searching.

Edit: Found it!