Stockpile additionally excluding decorations whenever edited to exclude any item type

Summary:
My Hearthlings refuses to place windows in my crates even tho i have set them to accept it and they are 0/32 and also my people dont want to put down the Carpenters Toolbench the second one you make for the carpenter for some reason
Steps to reproduce:

  1. Craft windows
  2. Set up crates with accepting doors and windows
  3. Watch em spread your windows all around the floor

Expected Results:
Working storage in the crates
Actual Results:
Placing them everywhere around the carpenters where we works
Notes:
This are all windows from the original game not any window from mods
Attachments:
Windows everywhere


Version Number and Mods in use:
Alpha 17 Develop 3010 (M)
Endpieces
Jomaxro Doorways
Spiros Windows
Settlement Decoration Mod

System Information:
i7 920
AMD 7950
12GB DDR3
Samsung 840
Samsung 830
WD 1TBx2
WD 4TB

Error at Start of World

I think i have found the bug to this issue now it seems that when i remove “Healing Items and Consumable” in filter it removes all furniture and windows from stockpiles and crates this is a screenshot to show

Look at all that stuff that went away from stockpile when i removed healing items from stockpile

Update
Dont seem to matter what i remove from the filter if i have set it to accept all it will take doors,windows,furnitures ect but the moment i remove anything this time i choose to remove armor and it removed all this stuff again so it might be a bug that requries your stockpile to accept everything for it to take these items. when i only had everything from construction it did never add any of these items like it should

It also seems as if you have to click the All to get it to work again to accept them.

Because lets say you remove one category of things and then you manually add them back without clicking all these items will not be added back until you click the box for ALL

Removed one category it drops out


When adding back Resources Category all is still dropped out

Clicking ALL adds it all back

1 Like

yup noticed this on my new save. Didn’t really notice it on my old one… But that one had its’ own problems… beyond the 2 items it would not stock at all.

However I noticed on my new save, as of the 3010 version it did this. Seems like in this one we have to stick to all category till it is sorted. Not sure what went wrong in the filter change over they did. But I am sure now that it is been put to light by quite a few people they at least are aware of it I am assuming. By now anyway. :slight_smile:

1 Like

Duplicate of
http://discourse.stonehearth.net/t/a17-dev-3010-hearthlings-will-not-store-furniture-confirmed/23110

Due to an abundance of awesomeness, I think this bug is fixed now (develop-3013)!

1 Like

Nope it is not

I unchecked “Cooked foods” and all the windows in the pile came along as well as some other items.

65587a68-1432-11e5-a0eb-bcee7be140d8

This is from a save from 3010 if that matters

Hrm. For me, it is working for construction items (with a save from 3010). I’m not sure if it makes a difference, but earlier today (when I was testing if the bug was fixed) I removed and recreated the buggy stockpile from 3010.

What isn’t working for me now (on 3013) is that “wealth” items (e.g. scout hats, goblin trophies, etc) refuse to go into stockpiles unless you select “all”. It’s like the same bug shifted to a different category of items.

Apparently, goblin honor tokens are not part of any category, which means that they are not able to be stored or undeployed, and therefore are not counted in the town’s inventory. It is therefore impossible to build The Valor of Cid, as two goblin honor tokens are required to build it.

I can have goblin tokens in my inventory because I can sell them. Is this what you mean or am I missing the point here… :smiley: hope this helped

You need to first “loot” it, as hearthlings will ignore items owned by enemies.

Yeah, I know this - when it was first dropped, it was sitting on the ground for days waiting to be picked up. I tried reloading and waiting until all the Hearthlings were done with their other tasks, but nothing ever worked. I was able to move it, and that is the only thing I can do with it. Attempting to undeploy, and it’ll sit there forever. Trying to move it again, someone will come take it down and pick it up, but just drop it again.

I’m having the same issue. Hearthlings never loot them and the only thing you can do is place them somewhere. Same thing happens with the firepit,

I am also having this same issue. Hearthlings never loot the tokens when told to. I can have them move the tokens, but when ordered to “undeploy” no hearthlings ever pick them up and move them to stockpiles. As mentioned above, this means I can not build the Valor of Cid.

I’m not sure what caused it, but it seems like the tokens aren’t put in stockpiles that don’t have All selected - if you exclude any item group from the stockpile, they won’t get put away. It seems like the same goes for kobold hats.

Calling attention to @sdee just in case! It seems like not all items were able to be filtered correctly

The problem is indeee that both decorations and furniture does not go intonstockpiles unless you allow all things to go in there.

There is another bug report topic about this

There was a bug in 3010 where not all items got moved to the new stockpile system. Build 3013 should have fixed most of them. I believe the goblin honor token is a part of the little gem icon (trophies). If it’s not working please upload your save and I will take a look.
Thanks
-Yang

https://drive.google.com/folderview?id=0B5swSxy1VpaJVm01ZVFCLVpMbFk&usp=sharing

Not sure if I did this correctly, as it’s my first time uploading a save.

There are several things strewn about the map, and I believe most if not all of them are goblin hats. I’m not sure if there are any more goblin tokens lying around, though there might be one or two.

I have a small cave set behind one of the houses outside the walls that stores valuables.

1 Like

Yep, 3010 fixed the furniture part of the bug, but now the goblin honor tokens are doing the exact same thing. The only way to get them into a stockpile is to select “All” for the contents of the stockpile.