Default filter option is set to none, but when starting a new save, storages are set to all


#1

Also reported here at Steam: Settings -> Gameplay -> Storage filters defaults to none not working :: Stonehearth Bug Reports

Steps:
Set your storage option to default to none.
Start a new game.
Create a stockpile.
The stockpile will be using the filter “all”.


#2

I am confirms this


#3

yes i noticed this aswell in my new savegame today…


#4

Hmm, I can’t to reproduce this following those steps. Any more details?


#5
  1. Start new game with filter default to none.
  2. Create stockpile zone
  3. Its ok
  4. Create any storage box and put it
  5. Filter is set to All

#6

Uhm, now that I opened the game, set it in the options (in the spalsh screen) to none and started a new game, the stockpile worked.

The last time, it was a microworld game and I had manually changed it in the user_settings.


#7

Ah, that worked. Looks like the fix for the reverse issue was trampled over by another change. Will be fixed in the next release. Thanks for cross-posting the report, Bruno, and thanks for the other repro steps, Nikolay!


#8

So just to check, next patch our crates will default to “none” if we have the option set? Because right now, it’s annoying to have to stop them from putting items in a new crate before you get a chance to filter the option. Thanks.


#9

And please fix this…


#10

Stockpile is correctly labeled, but crates are incorrect, labeled as “All”.