Some Problems/ rant about game


#1

I’ve started playing this game again after the latest update and, as much as I hate to say it, it really doesn’t feel finished. Let me say I’ve been playing this game for the better part of 3 years, just before the Ryas children were added, and I loved this game. I still love the same parts, beginning to make a settlement out of nothing; but thats where it ends. The later game, and all the newer things that come with it feel disjointed. IL explain:

The engineer seems almost useless because his turrets and traps consistently get destroyed. My city is so large that even one “secure” area with all the traps/ turrets/ firepower he is allowed to build, they still get destroyed by the time my solders get there. Its just infuriating trying to rebuild after every attack.

The building blueprints are still an annoyance to say the least. I made a post about it earlier, and it hasn’t changed. TBH its the part that drives me away from the game as I really don’t like building on my own. It is great that they added the workshop, with easier access to more blueprints than before. The problem is I have over 100, and want more nation-specific ones. Trying to find that one kitchen is already annoying enough, let alone having to sort through the dozens more im hoping to download. If there was a filing system it would be a great system, but alas there isnt. Mods maybe?

Mining, especially in the late game, is extremely laggy. about 70% of the meter in the bottom right is “Topography”. Normally i have about 10% of the bar as extra, but now its lagging out. I cant imagine what the geomacers mining drones will do to it, if they work at all.

Also, the new builder. I haven’t experimented with it much, but I tried to make one thing and it refuses to work. My plan was to create a spiral stair case through a mountain to get to a higher part of my city. It was going to poke through a building and exit in a big apartment like thing. the problem is once i dug the hole, the stairs wouldn’t build… and the stairs wouldn’t work… and the hole tool wouldn’t work. It could just be me, but its been pissing me off all night.

I have some really good memories of this game (I got over 370 hours), but when ever I play it, I get continually frustrated with it. their mostly simple things that could be ironed out, but development is over, and I feel this game deserves better.

I don’t know where im going with this and I know the development is now over. Maybe im just reminiscing and wishing it was as good as I remember, maybe im just ranting I dont know take this how you want too be it advice, a review, a warning, a call for help I don’t care im going to sleep il check tomorrow.


#2

The old template list was perfect. It had tabs for each kingdom so you could quickly see just those that match with what you are playing, and inside each tab they were grouped by tiers. All we need was the ability to create more tabs for other things besides just kingdoms and more groups besides just city tiers. For example, in the archipelago, the mod added a archipelago tab where all the templates from that mod would sit, and inside the list there was a specific group just for boats and the other for common houses.
But now it is just a huge single list…