[SOLVED] Help me, I'm new to modding

Hallo all,

after watching part 1 and 2 of the reference mod video, I tried to create my own mod.

It is a simple Rifle, for testing it should be craftable by the carpenter with little requirements. But it did not appear in the list.

When I look into the log file ther it says: Module steamheart version 1 is out of data (expected: 3). I don’t know what it tries to tell me :confused:

Also some other questions:

  • I inserted “enable_debug_keys”: true in my user_setting.json after “enable_analytics” : true, but it won’t work :confused:
  • how to disable the whole selection of faction, terrain type and threat level?
  • Do I have to restart the whole game and start a new game after changing some stuff in the .json files?

Here is a download link: https://www.dropbox.com/s/9g4pln2erkznio7/steamheart.zip?dl=0

Sorry for my bad english.


At your manifest, change the version to 3. This version is the game mod-engine version, not your mod version :slight_smile:


Not sure about this - can you copy/paste your user_settings.json?

You are probably looking for the microworld mod, assuming you wish to disable this for testing. Check it out on the teams Github: GitHub - stonehearth/microworld: Microworld Stonehearth Mod

Yes. If you use microworld from above, launch will be almost instant (no need to go to main menu, load a game, etc.

1 Like

@BrunoSupremo: Thank you! Now it is working!

@jomaxro: The microworld hint was great!

Odd, that worked for me…I copied your user settings and launched the game. Testing with F11 worked.

1 Like

F11… maybe the key is broken… Thought the Icons will display automaticly. Didn’t knew I have to press F11. Thanks man!

1 Like