Soldiers won't equip better items

Soldiers will equip the first piece of upgraded equipment, (i.e., a wooden shield instead of no shield, leather armor instead of no armor, stone maul instead of wood sword) but will ignore further upgrades, even if rallied near the equipment.

I had this exact same problem and managed to work around it and fix it in my game.
I recommend trying this yourself to see if it helps. If it doesn’t, we can try to think of something else to work around the bug.

[quote=“Wuelfe, post:10, topic:11497”]

  • Problem
    I had two of my three soldiers refusing to upgrade their gear (armour&weapons),

  • Solution
    Changed occupation of all soldiers to standard workers. Then changed them all back to soldiers again. This fixed the problem and they happily upgraded themselves.[/quote]

Additional Note: When you change the soldiers to workers, make sure you do them all at the same time, not one at a time.

Thank you, I will try that.

Should still be noted as a bug though.

Yup. I had it posted up a couple of days ago along with some other bugs here:
Warrior and Goblin Camp bugs

As well as that work around. :relieved:

If you could, could you please let me know if it works for you? :innocent:
If it doesn’t, I may try to search for more potential work arounds to test and add it to my summary in case other people experience and want to circumvent it.

I am having this same problem. I tried the prescribed cure, but it did not work. My main warrior still goes and grabs the wooden sword with no armor each and every time. I did make sure to change them from warrior to worker all at once, and then back again. I also tried putting all of the weapons in one storage chest. Nothing seems to help.

Hi @suneyedset
This is a known issue and I’ve put in some fixes in a15.
Have you tried saving after promoting them to a footman, and then loading that save after they are already footmen? Sometimes that fixes it.

I tried all these fixes, the fix described at the top by Wuelfe : change all soldiers to workers and back. This made all my footmen stay unequipped before it was just one, my knights, clerics, and archers are fine and re-equip but my warriors will not put on wolf helms and bone maces and stay naked with wooden swords… great, im in endgame with worthless dps melee classes, i’ve noticed a group of 2 of each soldier class option is undefeatable so far but with this kind of glitch im not even willing to play until my whole army will be outfitted i could just make 4 knights instead but that defeats the purpose of having 4 dps(2 ranged 2 melee) 2 tanks and 2 healers…