[Con] Footmen don't equip weapons & armor

noticed in alpha 8 that if the armor/weapons you create exist before you promote someone to footman they don’t go equip it. is there any way to force them to pick things up and use them?


My Mason did craft a hammer(weapon) before I even got a practise sword.
After promoting someone she went straight for the hammer and equipt it.

BUT selecting what weapon, shield and armor someone should wear is a good idea.

1 Like

thanks for the report @b3nw… I haven’t experienced this myself… can anyone confirm?

was this on the latest unstable build?

thats normal the wooden sword brings the promotion and the stone male is an upgrade^^

@steve nope cant confirm this - but with the new unstable version i have other bugs xD (normal issue ;))

First make sure if you haven’t have your stockpiles set with rules that unallow weapons in them.
Your soldiers will only gear up weapons and armour that are in a stockpile (the blacksmith will just drop them if there isn’t a stockpile for them).


I can confirm having sort of the same problem, i had a footman which would not pick up any upgrades for Armour or weapons. Even when in the stockpile. once created, a red error message pops up but i cannot read it.
I tried demoting and then re promoting them but still no fix.

I have a stream in my JWall LP thread which shows this (its too long to troll through tho) Its near the end of the stream, about 30 mins from the end

1 Like

sooo now i must confirm this too ^^ newst unstable x64 build - 2137 -> two footmen and two stone mace - and they patrolling next to the items but no notice ^^

I can confirm – dev2143 (x64) – Footmen and workers are not equipping any upgrades whatsoever.

1 Like

Can confirm, however this only started after day 12 for me, as there are couple of worker and footman with upgraded equipment wondering about.

I can confirm this bug also. (Dev 2143 x64). To test this bug, I had made the wooden shield. The stone mallet. The bronze armor, and steel sword.

Here is an older pic from today, with the bug. with Wooden Shield. (but same bug effect all weapons and armor.)

I had this bug too, on the most recent unstable build, as well as several workers not equipping their upgraded outfits.

For 3 footmen, I made 3 each of maces, wooden shields, and padded leather vests. I ended up with one using just a shield, one with a vest and mace, and one with a vest and shield. None of them had all three, and when I later made iron swords and shields, none of them equipped any of the iron goods.

I havethis exact same issue on Version 8 64-bit

So I had the same problem. I made a mace, a couple swords, some armor, and shields, but none of the footmen would pick them up. They were all in a large stock pile, I moved them to a smaller stock pile just for weapons and armor. All of my footmen sprinted over and upgraded their gear.

1 Like

@thisdrino which build? 205 stable or 2143 unstable x64 or x86? its important for the devs :wink:

I’m on the 2143 unstable x64

Ok so here has been my experience with this bug. I get a red error message in the top left (no screenshot yet, will post one later if I find time). This message appears whenever I craft something, maybe at the time it is placed in a stock pile or maybe it’s just right after crafting it. Either way, they then don’t pick up the upgrade unless it’s a wooden shield. In that case they DO pick it up, consistently, but they won’t grab any armor or weapons. Old veteran footmen and new footmen who just joined my town, doesn’t seem to matter. They won’t pick up the stockpiled pike, in a tiny stockpile, won’t pick up the steel sword in the big stockpile, won’t wear the padded or leather armor in a small stockpile. Not even when they patrol those stockpiles, still clinging to their wooden swords.

I’m running Dev2143 x64

Update: I’ve discovered items will be equipped ONLY if they are placed in a dedicated stockpile. This is the error generated EVERY time a piece of armor or a weapon is placed in any stockpile.

2015-Feb-07 22:02:48.982249 | server | 1 | lua.code | generating traceback…
2015-Feb-07 22:02:48.983250 | server | 0 | lua.code | – Script Error (lua) Begin -------------------------------
2015-Feb-07 22:02:48.983250 | server | 0 | lua.code | stonehearth/lib/entity_forms/entity_forms_lib.luac:17: attempt to index a nil value
2015-Feb-07 22:02:48.983250 | server | 0 | lua.code | stack traceback:
2015-Feb-07 22:02:48.983250 | server | 0 | lua.code | [C]: in function '__index’
2015-Feb-07 22:02:48.983250 | server | 0 | lua.code | stonehearth/lib/entity_forms/entity_forms_lib.luac:17: in function 'get_uris’
2015-Feb-07 22:02:48.984252 | server | 0 | lua.code | stonehearth/services/server/shop/sellable_item_tracker.luac:3: in function 'create_key_for_entity’
2015-Feb-07 22:02:48.984252 | server | 0 | lua.code | …ehearth/services/server/inventory/inventory_tracker.luac:5: in function 'add_item’
2015-Feb-07 22:02:48.984252 | server | 0 | lua.code | stonehearth/services/server/inventory/inventory.luac:24: in function 'add_item’
2015-Feb-07 22:02:48.984252 | server | 0 | lua.code | stonehearth/components/stockpile/stockpile_component.luac:142: in function '_add_item_to_stock’
2015-Feb-07 22:02:48.984252 | server | 0 | lua.code | stonehearth/components/stockpile/stockpile_component.luac:133: in function '_add_item’
2015-Feb-07 22:02:48.984252 | server | 0 | lua.code | stonehearth/components/stockpile/stockpile_component.luac:101: in function <stonehearth/components/stockpile/stockpile_component.luac:101>
2015-Feb-07 22:02:48.984252 | server | 0 | lua.code | – Lua Error End -------------------------------

I an also confirm an issue with equipping wooden bucklers got error messages 3 & 4, not sure about previous 2, as soon as my hearthies dropped the bucklers in the dedicated stock pile. I also made a wooden sword for my 2nd footman prior to the bucklers which was equipped.

Just made a dedicated light/heavy armour stockpile and my footmen still didn’t pick up the shields but… when some goblins turned up to party ONE of my footmen picked up a shield during the fight. He made one attempt went to run back to fight, changed his mind, then picked up the shield before returning to fight.
Edit: Rather than post again, game crashed so had to reload the save just before the goblins turned up. This time they didn’t pick the shields. When I made a stockpile and the shields got placed there with a recently made padded armour I thought I wonder if I convert a footman back to a worker will that work, it did they equipped the items.

What worked for me was to create a single solitary stockpile for weapons and armor. No other stockpiles allowed to have those items.

1 Like