[Con] v2133 x64 Hearthlings not upgrading

In the latest release hearthlings are not automatically upgrading equipment. Screens show both a worker’s outfit and a leather vest, second screen shows un-upgraded footmen.



I’ve got that issue, I have workers’ vests and bucklers in stockpiles and the relevant hearthies are not getting the equipment. Running the 64 bit latest build via steam.

1 Like

Yep have this issue as well! Im running 64bit also and my footmen wont use armor, Weapons, or shields!

1 Like

I’ve been having this same issue with all sorts of armor and weapons, but found a temporary solution. If you remove the stockpile that the items are in and they get moved to a new stockpile by a Hearthling, they can be picked up at that point.

Hopefully knowing this will help the devs find a solution.

1 Like

I got This error when i made some Wooden shields.

But my Footmen Did pick them up and used them

1 Like

I am receiving the same error display message as devoderek

I believe I got the error on the left, though I am not sure, when I tried to make shields as well. My guys wouldnt pick up the shields though.

I do believe I have the same problem.