Soldier's jagged combat and general movements and Wall Mounted Tapestries

Summary: Soldier’s Bug
As I was playing, day 22 of Deepmun I think, I made a party of 4 warriors and made them attack. However, the soldiers had very jagged combat and general movement, Yes it sounds like a performance issue, however, every object in game was still running smoothly e.g. workers walked and worked in flowing grace and goblins walked about with no signs of jaggedness. Also when my soldier’s attacked the goblins, they would stop mid-swing and try to swing again only to stop mid-swing again repeat the whole process. It got to a point where my soldier’s became ‘idle’ constantly swinging in place while their intended target already moved away. After about 5 - 10 mins of swinging they finally manage to pull through and function properly to kill the goblin camp. When they returned to my little town, 3 soldiers showed running motions but were not actually moving. Once again everything else was moving fine, so the chances of it being computer performance issues is slim.

Steps to perform:
1.) Made a party
2.) Attacked a goblin camp
3.) Jagged combat and general movements

Expected Results:
Fluid combat movements and general motion of soldiers

Actual Result:
Soldiers stopping mid-swing and tried to swing again only to stop mid-swing once again and this is repeated for roughly 5-10 minutes. Some soldiers running back to base would show movements but not actually move.

Summary: Wall Mounted Tapestry
I tried placing a wall mounted tapestry to liven up my hearthling’s cavern rooms however worker’s did not place the tapestry at all. They would place the ladder but then became idle or simply rested by the fire without placing the tapestry. There were no other furnitures blocking their path.

Steps to perform:
1.) Place Wall-mounted tapestry on a cavern wall.

Expected Result:
Expected the tapestry to be placed on wall and ladder created by hearthlings to be dismantled after tapestry is placed.

Actual Result:
Ladder was created, however, Tapestry was not placed leaving behind the ghosted image of the item on the wall. Ladder was not removed.



Hey @kcee, welcome to the discourse, and awesome job using the bug report template on your first bug report! Two quick questions for you. 1) what version are you getting this error in, 2) can you upload your save folder where this is happening (post a link to a shared folder in dropbox, google drive, or a similar cloud service) so TR can take a look?

On a separate note, paging @8bitcrab, @Relyss, and @SteveAdamo: while the description is a little different, this seems very much like that other footman issue reported yesterday…with the strange movements and the running in place…
Edit: Here we go!


Hi and thank you very much for the welcome.
So sorry I forgot to mention the version, it is 0.12.0 (develop 2650) x64 build. And here is the link for the file Dropbox - Stonehearth